Bug 172362 - libjava/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkToolkit.c: line 88 (gdk_env): assertion failed
libjava/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkToolkit.c: line 88 (gdk_env): a...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
:
: 178376 (view as bug list)
Depends On:
Blocks: 172149
  Show dependency treegraph
 
Reported: 2005-11-03 07:47 EST by Caolan McNamara
Modified: 2014-08-11 01:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: gcc-4.1.0-0.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-14 04:16:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2005-11-03 07:47:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Fedora/1.7.12-2

Description of problem:
crash on launching beanshell from within OOo...

** ERROR **: file ../../../libjava/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkToolkit.c: line 88 (gdk_env): assertion failed: ((*java_vm)->GetEnv(java_vm, &tmp.void_env, JNI_VERSION_1_2) == JNI_OK)
aborting...


Version-Release number of selected component (if applicable):
libgcj-4.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. oowriter
2. tools->macros->organize->beanshell...
3. OpenOffice.org->Capitalise->captalise.bsh
4. edit
  

Actual Results:  beanshell start up but then blows up with...

** ERROR **: file ../../../libjava/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkToolkit.c: line 88 (gdk_env): assertion failed: ((*java_vm)->GetEnv(java_vm, &tmp.void_env, JNI_VERSION_1_2) == JNI_OK)
aborting...


and the stack trace is then...
0x72f6f58: /lib/libc.so.6 + 0x29f58 (abort + 0xf8)
0x499ee98: /usr/lib/libglib-2.0.so.0 + 0x2de98 (g_logv + 0x4fd)
0x499eece: /usr/lib/libglib-2.0.so.0 + 0x2dece (g_log + 0x29)
0x499ef3a: /usr/lib/libglib-2.0.so.0 + 0x2df3a (g_assert_warning + 0x6a)
0x4340f00: /usr/lib/lib-gnu-java-awt-peer-gtk.so.6 + 0x48f00 (Java_gnu_java_awt_peer_gtk_GtkToolkit_gtkInit + 0x0)
0x4342c1b: /usr/lib/lib-gnu-java-awt-peer-gtk.so.6 + 0x4ac1b
0x65580cc: /usr/lib/libgtk-x11-2.0.so.0 + 0x1160cc
0x11fabd8: /usr/lib/libgobject-2.0.so.0 + 0x8bd8 (g_closure_invoke + 0x11e)
0x1209213: /usr/lib/libgobject-2.0.so.0 + 0x17213
0x120a5c3: /usr/lib/libgobject-2.0.so.0 + 0x185c3 (g_signal_emit_valist + 0x41e)
0x120abc3: /usr/lib/libgobject-2.0.so.0 + 0x18bc3 (g_signal_emit + 0x29)
0x663a4ff: /usr/lib/libgtk-x11-2.0.so.0 + 0x1f84ff
0x6556c54: /usr/lib/libgtk-x11-2.0.so.0 + 0x114c54 (gtk_main_do_event + 0x339)
0x4338bbf: /usr/lib/lib-gnu-java-awt-peer-gtk.so.6 + 0x40bbf (awt_event_handler + 0x2e)
0x11aa6f3: /usr/lib/libgdk-x11-2.0.so.0 + 0x3e6f3
0x4995a50: /usr/lib/libglib-2.0.so.0 + 0x24a50 (g_main_context_dispatch + 0x1dc)
0x4998a66: /usr/lib/libglib-2.0.so.0 + 0x27a66
0x4998f48: /usr/lib/libglib-2.0.so.0 + 0x27f48 (g_main_context_iteration + 0x66)
0x6c49d5b: /opt/openoffice.org/program/libvclplug_gtk680li.so + 0x18d5b
0x129814a: /opt/openoffice.org/program/libvclplug_gen680li.so + 0x4614a (X11SalInstance::Yield(unsigned char) + 0x28)
0x1917c8: /opt/openoffice.org/program/libvcl680li.so + 0x807c8 (Application::Yield() + 0x48)
0x1917fe: /opt/openoffice.org/program/libvcl680li.so + 0x807fe (Application::Execute() + 0x26)
0x806655d: /opt/openoffice.org/program/swriter.bin + 0x1e55d (desktop::Desktop::Main() + 0x1489)
0x196bcb: /opt/openoffice.org/program/libvcl680li.so + 0x85bcb
0x196c7b: /opt/openoffice.org/program/libvcl680li.so + 0x85c7b (SVMain() + 0x29)
0x80607b7: /opt/openoffice.org/program/swriter.bin + 0x187b7 (sal_main + 0x47)
0x72e250f: /lib/libc.so.6 + 0x1550f (__libc_start_main + 0xdf)

Additional info:

To see this you need openoffice.org ver 2.0.0-3.7.2 
(or for FC4 get the jar from bug 172149)
Comment 1 Tom Tromey 2005-11-03 15:10:39 EST
FWIW this bug is fixed in gcc svn.
I'm not sure whether it has made it into a gcc rpm yet.
The fix was:

2005-09-06  Tom Tromey  <tromey@redhat.com>

	PR libgcj/23739:
	* jni.cc (_Jv_JNI_IsAssignableFrom): Reversed arguments.
Comment 2 Tom Tromey 2005-11-03 15:13:09 EST
Darn it, I completely misread that assertion.
This is a different bug.  I suspect it is one I already
have a fix for; I will investigate a bit later.
Comment 4 Caolan McNamara 2005-12-14 04:16:28 EST
Works now in rawhide with gcc 4.1 update
Comment 5 Caolan McNamara 2006-01-20 03:57:07 EST
*** Bug 178376 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.