Bug 172365 - gnome-utils has new improper dependency on -devel rpms
gnome-utils has new improper dependency on -devel rpms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-03 08:13 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 14:41:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-03 08:13:14 EST
Description of problem:
root@tux:fc-devel# rpm -Uvh gnome-utils-2.13.1-1.i386.rpm
error: Failed dependencies:
        glib2-devel is needed by gnome-utils-2.13.1-1.i386
        gtk2-devel is needed by gnome-utils-2.13.1-1.i386
        libgnome-devel is needed by gnome-utils-2.13.1-1.i386
        libgnomeui-devel is needed by gnome-utils-2.13.1-1.i386


Version-Release number of selected component (if applicable):
gnome-utils-2.13.1-1

How reproducible:
100%

Steps to Reproduce:
1.rpm -Uvh gnome-utils-2.13.1-1.i386.rpm
2.
3.
  
Actual results:


Expected results:
Shouldn't be necessary to install any -devel rpms

Additional info:
Problem is new with this version.
Comment 1 John Ellson 2005-11-03 09:34:18 EST
These were added by Matthias Clasen <mclasen@redhat.com> on October 13.

    Requires: glib2-devel
    Requires: libgnome-devel
    Requires: libgnomeui-devel
    Requires: gtk2-devel

He probably intended BuildRequires, but the only one not already there would be:
    BuildRequires: libgnome-devel
Comment 2 Ray Strode [halfline] 2005-11-03 14:41:51 EST
Should be fixed in tomorrow's rawhide.

Note You need to log in before you can comment on or make changes to this bug.