Bug 172365 - gnome-utils has new improper dependency on -devel rpms
Summary: gnome-utils has new improper dependency on -devel rpms
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-03 13:13 UTC by John Ellson
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-11-03 19:41:51 UTC


Attachments (Terms of Use)

Description John Ellson 2005-11-03 13:13:14 UTC
Description of problem:
root@tux:fc-devel# rpm -Uvh gnome-utils-2.13.1-1.i386.rpm
error: Failed dependencies:
        glib2-devel is needed by gnome-utils-2.13.1-1.i386
        gtk2-devel is needed by gnome-utils-2.13.1-1.i386
        libgnome-devel is needed by gnome-utils-2.13.1-1.i386
        libgnomeui-devel is needed by gnome-utils-2.13.1-1.i386


Version-Release number of selected component (if applicable):
gnome-utils-2.13.1-1

How reproducible:
100%

Steps to Reproduce:
1.rpm -Uvh gnome-utils-2.13.1-1.i386.rpm
2.
3.
  
Actual results:


Expected results:
Shouldn't be necessary to install any -devel rpms

Additional info:
Problem is new with this version.

Comment 1 John Ellson 2005-11-03 14:34:18 UTC
These were added by Matthias Clasen <mclasen@redhat.com> on October 13.

    Requires: glib2-devel
    Requires: libgnome-devel
    Requires: libgnomeui-devel
    Requires: gtk2-devel

He probably intended BuildRequires, but the only one not already there would be:
    BuildRequires: libgnome-devel

Comment 2 Ray Strode [halfline] 2005-11-03 19:41:51 UTC
Should be fixed in tomorrow's rawhide.


Note You need to log in before you can comment on or make changes to this bug.