Bug 17240 - Pinstripe NFS install seems to be broken with non-Linux NFS servers
Pinstripe NFS install seems to be broken with non-Linux NFS servers
Status: CLOSED DUPLICATE of bug 17609
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-09-04 18:00 EDT by Anders Blomdell
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-24 12:40:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anders Blomdell 2000-09-04 18:00:30 EDT
Pinstripe seems to exhibit the same behaviour as in bug #9276, an install 
over NFS from a Sun Solaris system hangs. A network trace of what [doesn't] 
go on can be found at: 

Comment 1 panu.matilainen 2000-09-13 02:59:53 EDT
Same happens on when trying to NFS-mount from NetApp (Ontap 5.3.4R2) - mounts
from Linux NFS-server does work though. This is by the way present in Rawhide
too, though the details differ. Here's the copy of my post to pinstripe-list to
which nobody had anything to say :)
Date: Mon, 11 Sep 2000 14:27:05 +0300 (EEST)
From: "Matilainen Panu (NRC/Helsinki)" <panu.matilainen@nokia.com>
To: pinstripe-list@redhat.com
Subject: NFS installation from NetApp filers fails on pinstripe


Found a rather nasty (for me at least) issue with pinstripe + current
rawhide installer: it can't NFS-mount from NetApp filers at all though
installing from Linux NFS-server does work. RH6.2 has no problems with
this (install tree is world mountable as read only) at all so it's not a
problem with permissions/NetApp configuration.

Pinstripe installer would seem to get the proper information from
DHCP-server but both kickstart and manual installation over NFS fail from
NetApp. If I install from a Linux NFS-server it works just fine and then
if I try manually mounting from the shell:

#mkdir /tmp/foo
#mount netapp:/xxx/yyy/path/to/rh/image /tmp/foo
mount failed - invalid argument
#mount linux:/xxx/yyy/path/to/rh/image /tmp/foo
..no problemo

The same happens both with a static IP and when using DHCP.

Rawhide (Aug 11) bootnet.img is a bit of a different story: DHCP only gets
an IP-address, netmask and default-gw, but no nameserver nor
kickstart-information (it just seems to dismiss them) and will then ask
for nameserver IP. But... this time it can't install from either Netapp or
Linux-NFS server :( If I give it a static IP then install works from Linux
NFS but still not from NetApp ..

BTW mounting is ok once the system is up and running - this is just during the
Comment 2 panu.matilainen 2000-10-02 07:52:57 EDT
The bug is present also on official RH7. Bad...
Comment 3 Michael Fulbright 2000-10-09 14:56:20 EDT
Apparently related to bug 18087 and bug 17609.
Comment 4 panu.matilainen 2000-10-10 03:34:32 EDT
Not only related but exactly the same problem. There also is a working fix
posted by tek@cs.princeton.edu at bug 17609.
Comment 5 Michael Fulbright 2000-10-24 12:40:14 EDT

*** This bug has been marked as a duplicate of 17609 ***

Note You need to log in before you can comment on or make changes to this bug.