Bug 1724031 - python3-GeographicLib subpackage is missing .egg-info/.dist-info
Summary: python3-GeographicLib subpackage is missing .egg-info/.dist-info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: GeographicLib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-26 05:53 UTC by Elliott Sales de Andrade
Modified: 2019-07-08 22:57 UTC (History)
4 users (show)

Fixed In Version: GeographicLib-1.49-9.fc30 GeographicLib-1.49-5.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-08 01:08:41 UTC


Attachments (Terms of Use)

Description Elliott Sales de Andrade 2019-06-26 05:53:47 UTC
Description of problem:
GeographicLib is available from PyPI [1], which means that other packages rely on its metadata to exist. The python3-GeographicLib Fedora package does _not_ provide this metadata and this means the automatic Provides are not added.

This causes issues for consumers of this package (e.g., python-geopy, bug 1723052) because python3.7dist(geographiclib) is not provided by this package.


Version-Release number of selected component (if applicable):
1.49-8.fc31


Steps to Reproduce:
1. Create a Python 3 package that depends on GeographicLib (e.g., python-geopy, bug 1723052).
2. Automatic Requires will be added on python3.7dist(geographiclib)


Actual results:
The produced python3-geopy cannot be installed because its automatic Requires on python3.7dist(geographiclib) cannot be fulfilled.


Expected results:
python3-GeographicLib is installed as a dependency of python3-geopy.


Additional info:
[1] https://pypi.org/project/geographiclib/

Comment 1 Miro Hrončok 2019-06-26 08:53:12 UTC
The reason is GeographicLib doesn't use setuptools but installs the module by cmake.

Comment 2 Rich Mattes 2019-06-27 02:34:53 UTC
I just tweaked the spec to use the %py3_build/%py3_install macros and it seems to work and generate the correct Provides:

$ rpm -q --provides ./noarch/python3-GeographicLib-1.49-8.fc31.noarch.rpm
python3-GeographicLib = 1.49-8.fc31
python3.7dist(geographiclib) = 1.49
python3dist(geographiclib) = 1.49

I'll get the updates out to rawhide and f30 tomorrow.

Comment 3 Fedora Update System 2019-06-28 00:16:35 UTC
FEDORA-2019-9af4ea608b has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9af4ea608b

Comment 4 Fedora Update System 2019-06-28 00:16:40 UTC
FEDORA-2019-17548c0c7d has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-17548c0c7d

Comment 5 Fedora Update System 2019-06-28 18:25:37 UTC
GeographicLib-1.49-9.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9af4ea608b

Comment 6 Fedora Update System 2019-06-28 21:44:25 UTC
GeographicLib-1.49-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-17548c0c7d

Comment 7 Fedora Update System 2019-07-08 01:08:41 UTC
GeographicLib-1.49-9.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2019-07-08 22:57:18 UTC
GeographicLib-1.49-5.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.