Bug 172421 - qalculate-gtk needs to be rebuilt against cln-1.1.10
qalculate-gtk needs to be rebuilt against cln-1.1.10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qalculate-gtk (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 03:03 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 11:41:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2005-11-04 03:03:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/1.3.21

Description of problem:
Upgrading of libqalculate and cln fails because qalculate-gtk has not be rebuilt against the new cln.

Version-Release number of selected component (if applicable):
qalculate-gtk-0.8.2-4.fc4

How reproducible:
Always

Steps to Reproduce:
1. sudo yum upgrade
2.
3.
  

Actual Results:  $ sudo yum upgrade
Setting up Upgrade Process

[...]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package graphviz-doc.i386 0:2.6-1.fc4 set to be updated
---> Package cln.i386 0:1.1.10-1.fc4 set to be updated
---> Downloading header for octave-forge to pack into transaction set.
octave-forge-2005.06.13-1 100% |=========================| 123 kB    00:00
---> Package octave-forge.i386 0:2005.06.13-10.fc4 set to be updated
---> Package ginac.i386 0:1.3.3-1.fc4 set to be updated
---> Package graphviz-devel.i386 0:2.6-1.fc4 set to be updated
---> Package graphviz-tcl.i386 0:2.6-1.fc4 set to be updated
---> Package graphviz.i386 0:2.6-1.fc4 set to be updated
---> Package graphviz-graphs.i386 0:2.6-1.fc4 set to be updated
---> Downloading header for libqalculate to pack into transaction set.
libqalculate-0.8.2-3.fc4. 100% |=========================| 4.8 kB    00:00
---> Package libqalculate.i386 0:0.8.2-3.fc4 set to be updated
---> Downloading header for kxdocker to pack into transaction set.
kxdocker-0.39-2.fc4.i386. 100% |=========================| 7.0 kB    00:00
---> Package kxdocker.i386 0:0.39-2.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libcln.so.3 for package: qalculate-gtk
--> Processing Dependency: kxdocker-resources for package: kxdocker
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kxdocker-resources to pack into transaction set.
kxdocker-resources-0.14-3 100% |=========================|  80 kB    00:00
---> Package kxdocker-resources.noarch 0:0.14-3.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libcln.so.3 for package: qalculate-gtk
--> Finished Dependency Resolution
Error: Missing Dependency: libcln.so.3 is needed by package qalculate-gtk



Expected Results:  qalculate-gtk should have also ben upgraded

Additional info:
Comment 1 Alex Lancaster 2005-11-04 05:07:59 EST
It appears that build system dependencies nixed the fc4 job:

http://buildsys.fedoraproject.org/build-status/job.psp?uid=576

Now that libqalculate is available in the repository and is built against the
most recent cln, I'm guessing this job should go through.
Comment 2 Deji Akingunola 2005-11-04 11:41:05 EST
Yeah, you're right Alex. I've re-requested a new build, and it now got through.
New qalculate-gtk should be available in the next batch of updates.

Note You need to log in before you can comment on or make changes to this bug.