Bug 172432 - Lack of diskdump on swap partition explanation in doc
Lack of diskdump on swap partition explanation in doc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Akira Imamura
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-11-04 06:41 EST by masanari iida
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHEA-2006-0488
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:37:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2005-11-04 06:41:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.11) Gecko/20050728

Description of problem:
diskdumputils on RHEL4 Update2 start to support dump on swap partition.
But documentation is not enough.
- Noting is coumented in README file, but only on web page
  https://rhn.redhat.com/errata/RHEA-2005-578.html
  > This package allows the swap partition to be used in lieu of a dedicated
  > dump partition. This simply requires that the administrator configure
  > the swap device as the DEVICE in /etc/sysconfig/diskdump. 
  
- The web page doesn't explain some cases such as,
  1GB RAM and 2GB swap partition should be OK.
  2GB RAM and 2GB swap partition..  is it big enough to satisfy total_bloks?
  16GB RAM and 2GB x 8 swap partitions. Can we specify multiple swap partitions
  as dump partition?
  Or can we have one 16GB partition for swap? (I think Red Hat support max 2GB
  partition just because it is not tested by Red Hat.)

  My question is, if customer has more than 2GB memory, how can we setup 
  diskdump to swap partition(s)??
  Please write down the limitation in the document.


Version-Release number of selected component (if applicable):
diskdumputils-1.1.9-4

How reproducible:
Always

Steps to Reproduce:
1. See /usr/share/doc/diskdumutils-/README
2.
3.
  

Actual Results:  No detail info about diskdump to swap partition

Expected Results:  Detail info about diskdump to swap partition should be found in README.

Additional info:
Comment 1 Akira Imamura 2006-02-10 16:01:54 EST
>- The web page doesn't explain some cases such as,
>  1GB RAM and 2GB swap partition should be OK.
That's correct.

>  2GB RAM and 2GB swap partition..  is it big enough to satisfy total_bloks?
It would be OK if the swap partition size contains both header size
and bitmap size in addition to the RAM size.

>  16GB RAM and 2GB x 8 swap partitions. Can we specify multiple swap partitions
>  as dump partition?
No, you can't because diskdump is not currently able to switch a dump device
that is in use to another device that is not in use while memory dumping.

>  Or can we have one 16GB partition for swap? (I think Red Hat support max 2GB
>  partition just because it is not tested by Red Hat.)
I don't assure you can do that. I found more than 2 GB memory was swapped
on my own machine. However I've never verified 16 GB memory is swapped fully.
Although only 2 GB may be available for swap even if 16 GB swap partition is
configured, it can be fully used as a dump partition for diskdump at least.

>  My question is, if customer has more than 2GB memory, how can we setup 
>  diskdump to swap partition(s)??
In the case like that, they need to configure at least 2 GB swap partition
for a dump partition. If the swap partition is not enough to swap on their
system, then more swap partitions should be configured, which are not
related to diskdump.

>  Please write down the limitation in the document.
Sure. I'll do that.

Akira
Comment 3 Jay Turner 2006-03-23 14:49:46 EST
QE ack.  Testing being done by Fujitsu.
Comment 4 Bob Johnson 2006-04-11 12:09:21 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 5 Dave Anderson 2006-05-09 11:24:20 EDT
Fix checked in to RHEL4-U4 CVS, version 1.3.6-1
Comment 9 Red Hat Bugzilla 2006-08-10 17:37:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2006-0488.html

Note You need to log in before you can comment on or make changes to this bug.