Bug 172460 - ccs needs BuildRequires: libxml2-devel
ccs needs BuildRequires: libxml2-devel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
: 182085 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 15:55 EST by Matt Hyclak
Modified: 2009-04-16 16:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.2-0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 18:05:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Hyclak 2005-11-04 15:55:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Galeon/1.3.21

Description of problem:
Trying to build ccs in a mock environment fails because there is no explicit BuildRequires: libxml2-devel

Version-Release number of selected component (if applicable):
All versions up to and including CVS 4U2 20051104

How reproducible:
Always

Steps to Reproduce:
1. Try to build ccs without libxml2-devel installed
2. Watch it fail
3. Install libxml2-devel
4. Watch it succeed
  

Actual Results:  As expected it fails without libxml2-devel installed

Additional info:
Comment 1 Chris Feist 2005-11-14 17:55:26 EST
Will be fixed in the next release of ccs.
Comment 2 Chris Feist 2005-11-14 18:05:16 EST
This is actually fixed in current release of ccs (1.0.2-0)
Comment 3 Matt Hyclak 2005-11-14 18:33:25 EST
Will this be backported to the RHEL4 tag in the CVS tree, or would I be better
off just getting things out of rawhide?
Comment 4 Chris Feist 2005-11-15 10:42:06 EST
The RPMS .spec files (and builds_srpms.pl script) are out of date and are not
used in our build environment.  I've removed them from cvs for now.
Comment 5 Chris Feist 2006-02-20 12:43:24 EST
*** Bug 182085 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.