Bug 172462 - kernel bug panic in kswapd
kernel bug panic in kswapd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 16:15 EST by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 11:08:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2005-11-04 16:15:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Updates-testing kernel for FC4 self reports a kernel "bug" panic for kswapd

The recorded oops dump is included below.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1633_FC4

How reproducible:
Sometimes

Steps to Reproduce:
1. install kernel 2.6.14-1.1633_fc4 from updates-testing
2. wait
3.
  

Actual Results:  Nov  4 07:31:26 wolves kernel: kernel BUG at include/linux/list.h:165!
Nov  4 07:31:26 wolves kernel: invalid operand: 0000 [#1]
Nov  4 07:31:26 wolves kernel: Modules linked in: nls_utf8 nfsd exportfs lockd nfs_acl parport_pc lp parport autofs4 smbfs sunrpc ipv6 ipt_REJECT ipt_state ip_conntrack nfnetlink iptable_filter ip_tables dm_mod video button battery ac ohci1394 ieee1394 ohci_hcd ehci_hcd i2c_sis96x i2c_core snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc sis900 mii ne2k_pci 8390 floppy ext3 jbd raid1 sata_promise libata sd_mod scsi_mod
Nov  4 07:31:26 wolves kernel: CPU:    0
Nov  4 07:31:26 wolves kernel: EIP:    0060:[<c0146253>]    Not tainted VLI
Nov  4 07:31:26 wolves kernel: EFLAGS: 00010002   (2.6.14-1.1633_FC4)
Nov  4 07:31:26 wolves kernel: EIP is at isolate_lru_pages+0xb2/0xc6
Nov  4 07:31:26 wolves kernel: eax: ffffffff   ebx: c0368b78   ecx: c100c6f8   edx: c100cb58
Nov  4 07:31:26 wolves kernel: esi: 0000000b   edi: c1ddff14   ebp: 0000000a   esp: c1ddfeac
Nov  4 07:31:26 wolves kernel: ds: 007b   es: 007b   ss: 0068
Nov  4 07:31:26 wolves kernel: Process kswapd0 (pid: 137, threadinfo=c1ddf000 task=c1ddb570)
Nov  4 07:31:26 wolves kernel: Stack: 00000020 00000000 c0368a80 c0368b60 c1ddff14 c01462d7 c1ddff1c c0368b78
Nov  4 07:31:26 wolves kernel:        c1ddff7c 00000020 00000000 00000001 c100d2c0 c1019b00 c101c820 c101cf20
Nov  4 07:31:26 wolves kernel:        c100e8a0 c100e880 c101b6e0 c10079a0 c101ea40 c101bb60 c1ddff04 c1ddff04
Nov  4 07:31:26 wolves kernel: Call Trace:
Nov  4 07:31:26 wolves kernel:  [<c01462d7>] shrink_cache+0x70/0x29a
Nov  4 07:31:26 wolves kernel:  [<c0146971>] shrink_zone+0x88/0xd6
Nov  4 07:31:26 wolves kernel:  [<c0146dc5>] balance_pgdat+0x20d/0x3e7
Nov  4 07:31:26 wolves kernel:  [<c014706a>] kswapd+0xcb/0x109
Nov  4 07:31:26 wolves kernel:  [<c012d996>] autoremove_wake_function+0x0/0x37
Nov  4 07:31:26 wolves kernel:  [<c0146f9f>] kswapd+0x0/0x109
Nov  4 07:31:26 wolves kernel:  [<c0101301>] kernel_thread_helper+0x5/0xb
Nov  4 07:31:26 wolves kernel: Code: 46 ff 39 04 24 7f 8f 8b 44 24 18 89 30 89 e8 83 c4 04 5b 5e 5f 5d c3 8b 07 89 50 04 89 02 89 7a 04 89 17 83 c5 01 e9 60 ff ff ff <0f> 0b a5 00 5b 24 32 c0 eb 90 0f 0b a6 00 5b 24 32 c0 eb 8d 55


Expected Results:  no panic

Additional info:
Comment 1 Dave Jones 2005-11-10 15:22:17 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 2 G.Wolfe Woodbury 2005-11-19 20:48:07 EST
The oops has not repeated since the updates.

Note You need to log in before you can comment on or make changes to this bug.