Bug 172479 - Multiple same specifications for /sbin/lvm.static.
Summary: Multiple same specifications for /sbin/lvm.static.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix
: 172591 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-05 00:06 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.27.2-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 11:52:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2005-11-05 00:06:09 UTC
Description of problem:
I'm getting the message "Multiple same specifications for /sbin/lvm.static." 
while installing rpm packages etc. This problem appeared the first time with
-12, IIRC.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.27.2-12
selinux-policy-targeted-1.27.2-13

How reproducible:
Everytime, install one of the policies and install after this another rpm 
package for example.

Actual results:
Unneeded message

Expected results:
No message ;-)

Comment 1 Robert Scheck 2005-11-05 14:22:49 UTC
Ah, found it in policy-20051021.patch - once (w|s)ould be enough:

@@ -55,6 +56,12 @@
 /usr/bin/partition_uuid        --      system_u:object_r:fsadm_exec_t
 /sbin/partprobe                --      system_u:object_r:fsadm_exec_t
 ')
+ifdef(`lvm.te', `', `
+/sbin/lvm.static       --      system_u:object_r:lvm_exec_t
+')
+ifdef(`lvm.te', `', `
+/sbin/lvm.static       --      system_u:object_r:lvm_exec_t
+')
 ifdef(`kudzu.te', `', `
 # kudzu
 /usr/sbin/kudzu        --      system_u:object_r:kudzu_exec_t

Comment 2 David Nielsen 2005-11-07 09:25:09 UTC
I can confirm this.

Comment 3 Daniel Walsh 2005-11-07 16:36:36 UTC
Fixed in selinux-policy-targeted-1.27.2-16

Comment 4 Trever Adams 2005-11-07 18:10:22 UTC
*** Bug 172591 has been marked as a duplicate of this bug. ***

Comment 5 Robert Scheck 2005-11-12 11:52:52 UTC
Fixed in 1.27.2-16 (works also), closing now.


Note You need to log in before you can comment on or make changes to this bug.