Bug 172481 - No good MP3 Sound for onboard Intel sound
No good MP3 Sound for onboard Intel sound
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 21:32 EST by Steven Nunez
Modified: 2015-01-04 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 21:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Nunez 2005-11-04 21:32:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I am having a problem with my on board sound card. Wavs play fine and so do WMA's when played in Mplayer, but if i play an MP3 or WMA in another program, it sounds crackly, and raspy. My kernel is 2.6.13-1.1532_FC4
 
And this is my lspci output:
00:00.0 Host bridge: Intel Corporation Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation PCI Express Graphics Port
00:1b.0 Class 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controllers cc=IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc: Unknown device 5b70
02:00.0 Ethernet controller: Intel Corporation: Unknown device 108b (rev 03)
05:05.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.have intel d945psn board
2.listen to crackly MP3
3.Profit!
  

Actual Results:  MP3's sound very bad. Raspy, and crackly.

Expected Results:  it should sound clear like the wma's and wav's.

Additional info:
Comment 1 Dave Jones 2005-11-10 15:20:50 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 2 Steven Nunez 2005-11-10 15:29:53 EST
It turned out to be the Alsa driver. I changed it to OSS and the buzzing
stopped. Now I have to figure out how to do that with apps that use GStreamer.
Comment 3 Rahul Sundaram 2005-11-10 15:41:32 EST
Switching to OSS isnt a good long term solution. OSS interface is deprecated in
the kernel in favor of ALSA and OSS support might be dropped in the near future.
It would good if you can check the status with the latest kernel update and
provide feedback while working with ALSA
Comment 4 Steven Nunez 2005-11-10 15:49:56 EST
Thanks. I will take care of it. Thank you.
Comment 5 Steven Nunez 2005-11-11 01:31:14 EST
It's still not working, even after I updated the kernel with yum. Any help is
great. Thanks.
Comment 6 Steven Nunez 2005-11-15 13:22:14 EST
Is there any other information I can give you to help get this solved? Changing
the OSS settings in XMMS works, but not for anything Gstreamer.
Comment 7 Dave Jones 2005-11-15 22:10:15 EST
reporting this to the upstream developers at http://alsa-project.org may get it
resolved quicker.
Comment 8 Steven Nunez 2005-12-02 10:34:07 EST
In order to fix this I had to go into all of my players and map the sound device
for PCM as hw:0,0. I hope this helps someone!
Comment 9 Dave Jones 2006-02-03 02:22:12 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 10 John Thacker 2006-05-04 21:53:33 EDT
It's an ALSA thing, which I think they've fixed upstream.  Has to do
with conversion of sounds from 44.1k to 48k or vice versa, and the
applications and/or driver requesting something which the chipset
can't do.  They have workarounds at their site too.

Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.