Bug 172485 - API fails to allow a channel admin to view channel subscribability for user in same org
API fails to allow a channel admin to view channel subscribability for user i...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
410
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Brandon Perkins
:
Depends On:
Blocks: 145467
  Show dependency treegraph
 
Reported: 2005-11-04 23:45 EST by Beth Nackashi
Modified: 2008-01-14 13:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 13:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2005-11-04 23:45:32 EST
Description of problem:
API fails to allow a channel admin to view channel subscribability for user and
channel in same org.  

[bnackash@rhino api_test]$ perl test_channel.software.is_user_subscribable.pl
--user apichanneladmin --target apiorgadmin --channel
i386-api-test-custom-base-channel
Fault returned from XML RPC Server, fault code -23: Named exception:
(permission_check_failure)
[bnackash@rhino api_test]$ perl test_channel.software.is_user_subscribable.pl
--user apichanneladmin --target apinormal --channel
i386-api-test-custom-base-channel
Fault returned from XML RPC Server, fault code -23: Named exception:
(permission_check_failure)

Decoder ring:
apichanneladmin is the channel admin in org 1
apinormal and apiorgadmin are normal and org-admin users in org 1
i386-api-test-custom-base-channel is owned by org 1

The channel admin can view own channel subscribability just fine:
[bnackash@rhino api_test]$ perl test_channel.software.is_user_subscribable.pl
--user apichanneladmin --target apichanneladmin --channel
i386-api-test-custom-base-channel
Can apichanneladmin subscribe to i386-api-test-custom-base-channel? Yes


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.  Create an org-admin user, a channel-admin user, and a normal user in the
same org.
2.  Create a custom base channel owned by the same org.
3.  Use ~svn/qa/api_test/test_channel.software.is_user_subscribable.pl to
attempt to view the channel subscribability to that custom channel for all users
in the org (see description).
  
Actual results:
Channel admin cannot view subscribability for any users in the org except self.

Expected results:
Channel admin should be able to view subscribability for all users in the org.

Additional info:
Comment 1 Beth Nackashi 2005-11-04 23:59:32 EST
or, you know what?  even easier:  Just test this on RHN channels.  You don't
even need the custom channel to reproduce this.

[bnackash@rhino api_test]$ perl test_channel.software.is_user_subscribable.pl
--user apichanneladmin2 --target apichanneladmin2 --channel rhel-i386-as-4-cluster
Can apichanneladmin2 subscribe to rhel-i386-as-4-cluster? Yes
[bnackash@rhino api_test]$ perl test_channel.software.is_user_subscribable.pl
--user apichanneladmin2 --target apinormal2 --channel rhel-i386-as-4-cluster
Fault returned from XML RPC Server, fault code -23: Named exception:
(permission_check_failure)
Comment 2 Beth Nackashi 2005-11-08 14:10:15 EST
You know, the more I think about this, the more I realize that this might not be
a bug, but more an RFE.  Since subscribability is a "user" property, rather than
a "channel" property, it is expected that a channel admin would not be able to
view subscribability.

Or am I wrong.
Comment 3 Brandon Perkins 2006-06-22 15:21:41 EDT
Some that slipped-through that should be on me.

Note You need to log in before you can comment on or make changes to this bug.