Bug 172513 - The 'user.delete' api call should be replaced with/supplemented by calls for enabling and disabling a user
Summary: The 'user.delete' api call should be replaced with/supplemented by calls for ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API   
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Brandon Perkins
URL: https://rhn.redhat.com/rpc/api/user/d...
Whiteboard:
Keywords:
Depends On:
Blocks: 169463
TreeView+ depends on / blocked
 
Reported: 2005-11-05 19:16 UTC by Robin Norwood
Modified: 2007-06-20 18:09 UTC (History)
1 user (show)

Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 18:49:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robin Norwood 2005-11-05 19:16:21 UTC
User deletion in hosted almost never works.  We should allow user
disabling/enabling via the API instead.

Comment 1 Michael Bowman 2005-11-08 15:56:52 UTC
User deletion is not allowed in hosted. It should *never* work ;)

Added disable/enable functionality to the api. This works in both hosted and
satellite.

Test plan
============
- Make sure you cannot delete users via the api in hosted
- Make sure you can delete users via the api in satellite
- Make sure you can enable/disable users in both environments. You should check
for the same functionality and use cases through the api as we have through the
web-ui; i.e., org admin -> normal user, org admin -> org admin, org admin ->
self, org admin -> self when last in org, etc..
rhn-svn/docs/planning/specs/rhn400/90665-user-deletion/testplan.txt




Comment 2 Brandon Perkins 2006-06-28 17:12:29 UTC
Not sure how this slipped through the cracks...but it should be aligned with 410.

Comment 3 Brandon Perkins 2006-06-28 17:14:19 UTC
Looks like this should have been on QA since 2005-11-08.

Comment 4 Brandon Perkins 2006-06-28 17:16:28 UTC
Verified.  Test code at:

svn/rhn-svn/trunk/qa/rpcapi/410/java/src/com/redhat/rhn/rpc/api/user/disable.java
svn/rhn-svn/trunk/qa/rpcapi/410/java/src/com/redhat/rhn/rpc/api/user/enable.java


Comment 5 Beth Nackashi 2006-07-19 18:49:58 UTC
moving to closed - currentrelease


Note You need to log in before you can comment on or make changes to this bug.