Bug 172526 - Allow easy turn off of fake bold and fake italic
Allow easy turn off of fake bold and fake italic
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-05 22:13 EST by Michael A. Peters
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: f7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 21:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2005-11-05 22:13:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
fontconfig now has a conf.d directory.
The /etc/fonts/fonts.conf file is not suppose to be edited by the system administrator, but contains instructions for fake italic and fake bold that can not be turned off (unless I'm missing something) without editing that file.

If the fake bold and fake italic were moved into an /etc/fonts/conf.d/ file and tagged as missingok in the rpm spec file, a system administrator could disable them by renaming them (to not start with a number) - and thus would not be required to edit a file that does not preserve edits upon updates.

Version-Release number of selected component (if applicable):
fontconfig-2.3.91.cvs20051031-1

How reproducible:
Always

Steps to Reproduce:
1. Disable fake embolding and fake italic
2. update fontconfig
3.
  

Actual Results:  After the update, fake embolding and fake italic are enabled again

Expected Results:  What happens should happen - the problem is that that file should try not to contain configuration options that can't be over-ridden by other directives.

Additional info:

Another solution that would require upstream patch is to allow blacklisting certain fonts from having fake bold or italic applied. But until then, a feature that can't be turned off really shouldn't be in a file that gets replaced with every update.
Comment 1 Michael A. Peters 2005-11-16 07:00:09 EST
There is a way to do what I want to do w/o globally disabling fake
italic/embolding - though it still (imho) would be nice if the fake italic/bold
were separate from the main fonts.conf file.
Comment 2 Rahul Sundaram 2005-11-16 07:05:35 EST
The above comment would suggest still keeping it open and let the maintainer
decide on the appropriate course of action here.
Comment 3 Red Hat Bugzilla 2007-02-05 14:27:43 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 4 Behdad Esfahbod 2007-10-25 21:49:32 EDT
It's now a symlink named /etc/fonts/conf.d/90-synthetic.conf.  Remove it and you
don't get them anymore.  But that's really broken behavior.

Note You need to log in before you can comment on or make changes to this bug.