Bug 172537 - xorg-x11 devel version on MacMini freezex computer
xorg-x11 devel version on MacMini freezex computer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-06 10:51 EST by John Eckerdal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 12:16:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckerdal 2005-11-06 10:51:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Description of problem:
If I install any version (tried previous versions of xorg-x11 from the development version) of xorg-x11 from FC-devel then I experience random crashes
on my MacMini.

It seems slightly related to the sound system but not entirely sure.

I use XFCE 4 (development version) and XFmedia.

I can use the new development version of as long as I do not try to listen to music, or sometimes even start the xfmedia application. Either I can listen to music for a while (in X) and then a freeze occurs or the freeze happens as soon as I open the xfmedia application.

I do not use the stock Red Hat kernel since this does not include power management to control the fan (atleast it did not in earlier versions making the fan run at full speed all times). I have experience these issues with kernels 2.6.12.5, 2.6.13.1 and 2.6.14.

Also if I enable DRI in the xorg-x11 config file I can not use X at all. The graphics do not seem so sync with the monitor correctly (the graphics is severely corrupted - it looks like one single pixel line is compressed into only a few pixels).

As included in the xorg-x11 config file below I also had to enable UseFBDev to get any useful graphical output (atleast with the standard FC4 xorg-x11 releases).


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-58.ppc

How reproducible:
Always

Steps to Reproduce:
1. Start X
2. Start xfmedia
3. Use computer in X and after a non-deterministic time a freeze will happen.

Actual Results:  The following operation causes freezes at random times.

Expected Results:  No freeze.

Additional info:

Every version I tried in the development version of X11 causes freezes.

CPU information:

processor       : 0
cpu             : 7447A, altivec supported
clock           : 1249MHz
revision        : 0.2 (pvr 8003 0102)
bogomips        : 1245.18
machine         : PowerMac10,1
motherboard     : PowerMac10,1 MacRISC3 Power Macintosh 
detected as     : 287 (Mac mini)
pmac flags      : 00000012
L2 cache        : 512K unified
memory          : 512MB
pmac-generation : NewWorld


lspci:00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
        Flags: bus master, 66Mhz, medium devsel, latency 16
        Capabilities: <available only to root>

00:10.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01) (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc RV280 [Radeon 9200]
        Flags: bus master, 66Mhz, medium devsel, latency 255, IRQ 48
        Memory at 0000000098000000 (32-bit, prefetchable) [size=128M]
        I/O ports at f0000400 [size=256]
        Memory at 0000000090000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at 00000000f1000000 [disabled] [size=128K]
        Capabilities: <available only to root>

0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 PCI
        Flags: bus master, 66Mhz, medium devsel, latency 16

0001:10:17.0 Class ff00: Apple Computer Inc. KeyLargo/Intrepid Mac I/O
        Flags: bus master, medium devsel, latency 16
        Memory at 0000000080000000 (32-bit, non-prefetchable) [size=512K]

0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB (prog-if 10 [OHCI])
        Flags: medium devsel

0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB (prog-if 10 [OHCI])
        Flags: medium devsel

0001:10:1a.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB (prog-if 10 [OHCI])
        Flags: bus master, medium devsel, latency 16, IRQ 29
        Memory at 0000000080083000 (32-bit, non-prefetchable) [size=4K]

0001:10:1b.0 USB Controller: NEC Corporation USB (rev 43) (prog-if 10 [OHCI])
        Subsystem: NEC Corporation USB
        Flags: bus master, medium devsel, latency 16, IRQ 63
        Memory at 0000000080082000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <available only to root>


0001:10:1b.1 USB Controller: NEC Corporation USB (rev 43) (prog-if 10 [OHCI])
        Subsystem: NEC Corporation USB
        Flags: bus master, medium devsel, latency 16, IRQ 63
        Memory at 0000000080081000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <available only to root>

0001:10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04) (prog-if 20 [EHCI])
        Subsystem: NEC Corporation USB 2.0
        Flags: bus master, medium devsel, latency 16, IRQ 63
        Memory at 0000000080080000 (32-bit, non-prefetchable) [size=256]
        Capabilities: <available only to root>

0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 Internal PCI
        Flags: bus master, 66Mhz, medium devsel, latency 16

0002:20:0d.0 Class ff00: Apple Computer Inc. UniNorth/Intrepid ATA/100
        Flags: bus master, medium devsel, latency 32, IRQ 39
        Memory at 00000000f5004000 (32-bit, non-prefetchable) [size=16K]

0002:20:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81) (prog-if 10 [OHCI])
        Subsystem: Apple Computer Inc. iBook G4 2004
        Flags: bus master, medium devsel, latency 64, IRQ 40
        Memory at 00000000f5000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <available only to root>

0002:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)
        Flags: bus master, 66Mhz, slow devsel, latency 16, IRQ 41
        Memory at 00000000f5200000 (32-bit, non-prefetchable) [size=2M]
        Expansion ROM at 00000000f5100000 [disabled] [size=1M]

xorg-x11 configuration file (parts of):
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        # Load  "dri"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Cinema Displ"
        DisplaySize  430        270
        HorizSync    30.0 - 75.0
        VertRefresh  60.0 - 60.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon 9200"
        # Option      "DynamicClocks" "yes"
        Option      "UseFBDev" "yes"
EndSection
Comment 1 Mike A. Harris 2005-11-06 13:07:35 EST
Please report this to X.Org bugzilla located at http://bugs.freedesktop.org
in the "xorg" component.  Be sure to attach your X server config file and
log file, and /var/log/messages to the report as individual uncompressed
file attachments to the upstream bug report, to assist X.Org PPC developers
in diagnosing the issue.

Once you've filed your report to X.Org, if you'd like Red Hat to track the
issue, paste the URL here.

Thanks in advance.
Comment 2 John Eckerdal 2005-11-09 17:33:46 EST
The URL to the freedesktop issue is:
https://bugs.freedesktop.org/show_bug.cgi?id=4999

However there is one thing I am not entirely sure of. This problem does not
happen with the FC4 version.

xorg-x11-6.8.2-37.FC4.49.2 works fine.
xorg-x11-6.8.2-58 (or any from the FC-devel) does not work.

I see I was very unclear about this. I am very sorry for that. Is this still an
issue for fdo?
Comment 3 John Eckerdal 2005-11-10 16:33:14 EST
I did some more poking around (this information is also added to the fdo bug):

The following has changed between the working (FC4) and the non-working
(FC-devel) version:

1. The most likely candidate: Modifications on how "Dynamic Clocks" are handeled
has been modified. My current configuration runs with default setting for
"DynamicClocks". According to the log file this defaults to off:

(II) RADEON(0): Dynamic Clock Scaling Disabled

Atleast if it is disabled then I get no freeze. I will try to install the newer
version again and disable dynamic clocks and see if I get the freeze.

The patch name is:
xorg-x11-6.8.2-ati-radeon-ppc-enable-dynamic-clocks.patch

Is this a RH patch or is the fix also in xorg-x11?


2. A patch to workaround volatile problems in gcc has been dropped since it
should be fixed in gcc-4.0.1-4 (RH build) which should have been used to compile
the package.

3. A modification enabling DRI for Radeon RV100 has been modified. This radeon
is an RV280 so this patch should not affect.

4. The patch for CAN-2005-2495 (allocating too large pixmaps) is not included in
the version that freezes

5. Support i945 is not included in the version that freezes (should not be
related since that is an Intel chip and this is not an Intel platform).

6. A leak in the shadow framebuffer is fixed in the non-freezing version.

7. A patch to remove ProPolice stuff is removed in the freezing version.

Comment 4 Mike A. Harris 2005-11-24 12:16:26 EST
> I do not use the stock Red Hat kernel since this does not include power
> management to control the fan (atleast it did not in earlier versions making
> the fan run at full speed all times). I have experience these issues with
> kernels 2.6.12.5, 2.6.13.1 and 2.6.14.

We do not support systems that have custom kernels installed.  Aside from
that though, since this report was filed in bugzilla, Fedora development
has made a major changeover from X.Org 6.8.2 to the X11R7 RC2 release of
modular Xorg.

It is highly recommended that you update to the latest Fedora development
packages, and that you use the Red Hat supplied kernel.  If you require
functionality not present in the Red Hat kernel, simply install the official
kernel plus a custom kernel, and when you experience any problems, be
sure to reboot into the Red Hat supported kernel and reproduce the problem
with the Red Hat kernel before filing a bug report.

If you still have this problem after upgrading to Fedora Core 5test1 and
updating to all of the latest RPM packages from Fedora development, please
update your X.Org bug report, or file a new one if the problem is different
from what was reported before.

Comment 5 John Eckerdal 2005-11-24 14:06:47 EST
The problem seems very kernel unrelated.

If I enable "Dynamic Clocks" in X I get instability. If I disable it it works.

Note You need to log in before you can comment on or make changes to this bug.