Bug 172568 - "up2date --register" fails with error "RHN Software Management service entitlements exhausted"
"up2date --register" fails with error "RHN Software Management service entitl...
Status: CLOSED DUPLICATE of bug 118884
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 07:10 EST by James Baum
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 16:54:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Baum 2005-11-07 07:10:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050427 Red Hat/1.7.7-1.1.3.4

Description of problem:
RHEL3U5, two new AS licenses activated on the red hat web.
I run 
/usr/bin/up2date --register          or
/usr/sbin/rhn_register
Enter user Sarpsborg with password. Enter one of two of the licenses activated above (or try without activation, all variants fail).
Try with or without sending hardware and package information to Red Hat.

All variants (X, --nox, with activation or without) fail with the following error:

Problem registering system:

Error Message:
    Registration failed: RHN Software Management service entitlements exhausted
Error Class Code: 91
Error Class Info: Registration token unable to entitle system: maximum membership exceeded
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Customer service UK was less than helpful and sent me to Dell who sold the licenses, even though it's obvious Dell can't help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above.
/usr/bin/up2date --register and enter any variant of the correct info.

Actual Results:  Problem registering system:

Error Message:
    Registration failed: RHN Software Management service entitlements exhausted
Error Class Code: 91
Error Class Info: Registration token unable to entitle system: maximum membership exceeded
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Expected Results:  The system should be subscribed to RHN and should update itself.

Additional info:
Comment 1 James Baum 2005-11-07 07:24:57 EST
rhnreg_ks --activationkey=(key omitted)

also fails with the same error message. The licenses are brand new, there is
only one othe machine registered with one other valid key, and the keys/licenses
are available according to red hats web site. :-(
Comment 2 James Baum 2005-11-08 06:50:15 EST
RHN says the following:

Entitlement Counts
Base Entitlements
Update Service: You have 4 subscriptions (including 1 Demo subscription), and
you have 1 system subscribed.
Comment 3 Red Hat Bugzilla 2007-04-11 20:21:36 EDT
User bnackash@redhat.com's account has been closed
Comment 4 Bryan Mason 2007-07-09 16:54:57 EDT

*** This bug has been marked as a duplicate of 118884 ***

Note You need to log in before you can comment on or make changes to this bug.