Bug 172588 - rescue mode dialogues are broken (maybe text mode install is too); can't enable networking
Summary: rescue mode dialogues are broken (maybe text mode install is too); can't enab...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 175181 178499 (view as bug list)
Depends On:
Blocks: 168429
TreeView+ depends on / blocked
 
Reported: 2005-11-07 17:35 UTC by Thomas Uebermeier
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2006-0126
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 21:31:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0126 qe-ready SHIPPED_LIVE anaconda bug fix update 2006-03-06 05:00:00 UTC

Description Thomas Uebermeier 2005-11-07 17:35:35 UTC
This bug is also existant on Red Hat Enterprise Linux 4 U2 for pSeries 
 
+++ This bug was initially created as a clone of Bug #153961 +++ 
 
Description of problem: 
anaconda text dialogues in rescue mode are messed up.  The ones presented by 
loader (language, keyboard) are ok; those presented after anaconda is started 
in 
rescue mode (networking, installed image selection) have odd characters, boxes 
are not lined up correctly, mostly unusable. 
 
If you enable networking, after selecting dhcp, anaconda will print a Python 
error because some __call__ is given 5 arguments where 6 were expected, or the 
other way round. 
 
I booted from the i386 rescuecd, without any arguments. 
 
Version-Release number of selected component (if applicable): 
FC4-re0405.0 
 
-- Additional comment from clumens@redhat.com on 2005-04-08 16:00 EST -- 
Appears to be fixed in FC4-re0407. 
 
-- Additional comment from katzj@redhat.com on 2005-04-12 11:57 EST -- 
Actually wasn't fixed there, but fixed in rawhide.

Comment 1 Paul Nasrat 2005-11-07 17:53:40 UTC
Obvioius fix to backport, rescue mode should work.

Comment 3 Bastien Nocera 2005-12-05 10:03:47 UTC
The error exists on x86, with RHEL4 U2, so setting the arch to all:

Traceback (most recent call last):
File "/usr/bin/anaconda", line 604 in ?
rescue.runRescue(rootPath, not rescue_nomount, id)
File "/usr/lib/anaconda/rescue.py", line 209 in runRescue
rc = apply(win, (screen, ) + args)b>/<Alt-Tab> between
elements | <Space> selects | <F12> next screen TypeError: __call__() takes
exactly 6 arguments (5 givien) 

Should be fixed in anaconda 10.1.1.26-1

Comment 4 Paul Nasrat 2005-12-07 15:26:23 UTC
*** Bug 175181 has been marked as a duplicate of this bug. ***

Comment 5 Suzanne Hillman 2005-12-27 15:00:28 UTC
Not sure if these problems would show up on a rescue boot of the DVD, or only if
using a disc which is only for rescue. However, if they would show up on a
rescue boot of the DVD, verified that it's fixed on RHEL4U3 re1221.0 for i386.

Comment 6 Paul Nasrat 2006-01-20 23:10:06 UTC
*** Bug 178499 has been marked as a duplicate of this bug. ***

Comment 10 Red Hat Bugzilla 2006-03-07 21:31:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0126.html


Comment 13 Issue Tracker 2007-06-19 08:32:57 UTC
Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'RHEL 4 U4'

This event sent from IssueTracker by uthomas 
 issue 82877


Note You need to log in before you can comment on or make changes to this bug.