Bug 172593 - Swap memory not being used
Swap memory not being used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 13:16 EST by ajs
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 10:22:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after an oom kill (15.98 KB, text/plain)
2005-11-07 15:23 EST, ajs
no flags Details
New dmesg (34.19 KB, text/plain)
2005-11-08 14:11 EST, ajs
no flags Details
kernel 1636: dmesg (34.25 KB, text/plain)
2005-11-14 12:05 EST, ajs
no flags Details
kernel 1636: slabtop -o -sc (1.38 KB, text/plain)
2005-11-14 12:08 EST, ajs
no flags Details
kernel 1637: dmesg (31.90 KB, text/plain)
2005-11-14 14:05 EST, ajs
no flags Details
kernel 1637: slabtop -o -sc (1.38 KB, text/plain)
2005-11-14 14:06 EST, ajs
no flags Details
kernel 1640: dmesg (38.69 KB, text/plain)
2005-11-15 12:15 EST, ajs
no flags Details
kernel 1640: dmesg (38.69 KB, text/plain)
2005-11-15 12:16 EST, ajs
no flags Details
kernel 1640: slabtop -o -sc (1.38 KB, text/plain)
2005-11-15 12:18 EST, ajs
no flags Details
kernel 1644: dmesg (39.01 KB, text/plain)
2005-12-01 19:31 EST, ajs
no flags Details
kernel 1644: slabtop -o -sc (1.39 KB, text/plain)
2005-12-01 19:32 EST, ajs
no flags Details

  None (edit)
Description ajs 2005-11-07 13:16:18 EST
Description of problem:

I have 2GB of swap, but every time that I check there is no swap being used. 
When swapping is required, the oom killer starts to kill processes.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4

How reproducible:
always


Steps to Reproduce:
1. start a process that will require swapping
2.
3.
  
Actual results:
oom killer starts

Expected results:


Additional info:
I don't know how to give more information.
Comment 1 ajs 2005-11-07 13:47:58 EST
swapon yields:

[seward@sonylap1 ~]$ /sbin/swapon -s
Filename                                Type            Size    Used    Priority
/dev/mapper/VolGroup00-LogVol01         partition       2031608 0       -1
Comment 2 Dave Jones 2005-11-07 15:16:13 EST
please show the output of 'dmesg' after an oom kill.
Comment 3 ajs 2005-11-07 15:23:34 EST
Created attachment 120793 [details]
dmesg after an oom kill
Comment 4 Dave Jones 2005-11-07 15:25:29 EST
theres no oom kill in that dmesg.
Comment 5 ajs 2005-11-07 15:29:05 EST
How long after the oom killer messages start showing up on the console do I have
to wait?
Comment 6 Dave Jones 2005-11-07 17:40:47 EST
they should be there instantly.
Comment 7 ajs 2005-11-08 14:11:54 EST
Created attachment 120821 [details]
New dmesg

When I'm at runlevel 5 the oom killer messages run all night and still don't
return.  Executing prelink in runlevel 3 invokes the oom killer but usually
does not result in a responsive system.  After several tries, I was able to end
up with a responsible enough system to redirect the dmesg output to a file. 
I've attached that file.
Comment 8 Dave Jones 2005-11-10 14:58:29 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 9 Dave Jones 2005-11-12 19:16:12 EST
can you paste the output of "slabtop -sc" after the oom killer has kicked in?
Comment 10 ajs 2005-11-14 12:05:30 EST
Created attachment 121026 [details]
kernel 1636: dmesg

Here is the dmesg after the oom killer with kernel 1636
Comment 11 ajs 2005-11-14 12:08:58 EST
Created attachment 121028 [details]
kernel 1636: slabtop -o -sc

Here is the result of slabtop -o -sc after the oom killer with kernel 1636
Comment 12 ajs 2005-11-14 12:13:40 EST
Oops!  I just noticed that you asked about kernel 163_7_.  I'm downloading now.
Comment 13 ajs 2005-11-14 12:22:59 EST
Oops!  I just noticed that you asked about kernel 163_7_.  I'm downloading now.
Comment 14 ajs 2005-11-14 14:05:39 EST
Created attachment 121034 [details]
kernel 1637: dmesg
Comment 15 ajs 2005-11-14 14:06:28 EST
Created attachment 121035 [details]
kernel 1637: slabtop -o -sc
Comment 16 Dave Jones 2005-11-14 14:24:29 EST
there's a 1640 being built right now which will appear at
http://people.redhat.com/davej/kernels/Fedora/FC4/ in a while, which contains a
fix for a memory leak in the file leases code. This could explain why all your
memory is being consumed by slab cache.  If this solves your problem, then this
is a dupe of bug 172691
Comment 17 ajs 2005-11-15 12:15:56 EST
Created attachment 121074 [details]
kernel 1640: dmesg
Comment 18 ajs 2005-11-15 12:16:08 EST
Created attachment 121075 [details]
kernel 1640: dmesg
Comment 19 ajs 2005-11-15 12:18:57 EST
Created attachment 121076 [details]
kernel 1640: slabtop -o -sc
Comment 20 ajs 2005-11-15 12:20:03 EST
Kernel 1640 was did not fix the problem.
Comment 21 ajs 2005-11-30 12:55:41 EST
kernel-2.6.14-1.1644_FC4 did not help things.
Comment 22 ajs 2005-11-30 13:05:12 EST
Do you want new dmesg and slabtop output?
Comment 23 Dave Jones 2005-11-30 13:36:27 EST
yes please.
Comment 24 ajs 2005-12-01 19:31:16 EST
Created attachment 121724 [details]
kernel 1644: dmesg
Comment 25 ajs 2005-12-01 19:32:22 EST
Created attachment 121725 [details]
kernel 1644: slabtop -o -sc
Comment 26 ajs 2005-12-01 19:35:23 EST
I have been able to get the system to use some swap by opening several large
mozilla sessions, Matlab and VMware.  This seems to work OK, but prelink still
triggers the oom kller.
Comment 27 Dave Jones 2005-12-02 00:22:51 EST
what we really need to know is whats happening in the slabcache at the time that
the kill happens. Can you run slabtop in an xterm, and trigger the prelink
cronjob manually, and watch the output. Do you see buffer_head growing to the
top of the list perhaps, and then disappearing after the kill ?
Comment 28 ajs 2005-12-02 17:19:45 EST
size-64 gets huge right before the kill
Comment 29 ajs 2006-01-16 10:22:10 EST
I can no longer replicate the bug with kernel version 2.6.14-1.1656_FC4.

Note You need to log in before you can comment on or make changes to this bug.