Bug 172640 - Yum update attempts to access to mirrorlist entries when it should not
Yum update attempts to access to mirrorlist entries when it should not
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 15:58 EST by Amit Shenoy
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 16:01:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shenoy 2005-11-07 15:58:35 EST
Description of problem:
Setup information:
------------------
I have my fedora machine on a private network not accessible to outside world
(www)
I modified /etc/yum.conf file to make it point to the ftp server accessible to 
this machine to get the updates
then i issued "yum update" command

It takes about 5-6 minutes before it would begin to carry out the update 
process for packages

The reason as we found out later was that it was attempting to access the 
mirror list entries inside *.repo files under /etc/yum.repos.d directory and 
these entries were :

mirrorlist=http://fedora.redhat.com/download/mirrors/...

I verified the setting that
enabled=0

Thus 'yum update' operation was attempting to establish connection to this 
mirror site even though it was not supposed to be doing since we had disabled 
it.

As a result, it was taking about 5 minutes before it timed out doing this and 
then proceeded to gather the updates correctly

yum operation should not be attempting to connect to these mirror sites when 
they have been disabled.


Version-Release number of selected component (if applicable):

yum-2.1.11 and kernel 2.6.12.2

How reproducible:

Every Time


Steps to Reproduce:

1. have Fedora linux machine on a private test network say 192.168.x.x and 
accessible to a ftp server that hosts all packages (as accessed by yum)
make sure you donot have access or route to outside world (www) from this 
linux machine via any gateway

2. Edit /etc/yum.conf file to point to the correct accessible ftp server by 
making changes to the "baseurl" attribute

3. Now issue "yum -d 10 update" command  

Actual results:

It will take about 4-5 minutes before it starts displaying any output on 
console.

Expected results:

The operation should have been prompt and should display the packages that are 
being downloaded from ftp server


Additional info:
Comment 1 Seth Vidal 2005-11-07 16:01:02 EST
this is fixed in later versions of yum.

upgrade to 2.2.1 or higher.

better yet, upgrade to fedora core 4 and yum 2.4.0 or higher.
Comment 2 Seth Vidal 2005-11-07 16:01:40 EST
this is fixed in later versions of yum.

upgrade to 2.2.1 or higher.

better yet, upgrade to fedora core 4 and yum 2.4.0 or higher.

Note You need to log in before you can comment on or make changes to this bug.