Bug 172675 - Fontconfig upgrade causes programs to crash
Fontconfig upgrade causes programs to crash
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Carl Worth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-08 01:37 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 02:51:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-11-08 01:37:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
This is evince. Thunderbird refuses to start as well. If I recompile fontconfig-2.3.91.cvs20051031 from srpm things work fine.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209190736 (LWP 28820)]
FcFreeTypeCharIndex (face=0x0, ucs4=70) at fcfreetype.c:2311
2311        if (face->charmap)
(gdb)
(gdb)
(gdb) bt
#0  FcFreeTypeCharIndex (face=0x0, ucs4=70) at fcfreetype.c:2311
#1  0x00e89152 in pango_fc_font_create_metrics_for_context () from /usr/lib/libpangoft2-1.0.so.0
#2  0x00e892f0 in pango_fc_font_get_glyph () from /usr/lib/libpangoft2-1.0.so.0
#3  0x00a64e21 in ?? () from /usr/lib/pango/1.4.0/modules/pango-basic-fc.so
#4  0x0047ac87 in pango_engine_shape_get_type () from /usr/lib/libpango-1.0.so.0
#5  0x00489ad9 in pango_shape () from /usr/lib/libpango-1.0.so.0
#6  0x0047e1e2 in pango_layout_set_width () from /usr/lib/libpango-1.0.so.0
#7  0x004807cb in pango_layout_iter_get_char_extents () from /usr/lib/libpango-1.0.so.0
#8  0x00481028 in pango_layout_iter_get_char_extents () from /usr/lib/libpango-1.0.so.0
#9  0x00481957 in pango_layout_iter_get_char_extents () from /usr/lib/libpango-1.0.so.0
#10 0x00fb24b7 in gtk_label_get_use_underline () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x00ef1fb6 in gtk_accel_label_refetch () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x00529b65 in g_cclosure_marshal_VOID__BOXED () from /usr/lib/libgobject-2.0.so.0
#13 0x0051d5a5 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#14 0x0051dbd8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#15 0x0052be69 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#16 0x0052d850 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x0053047f in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#18 0x0100945d in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x010097f9 in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x010a2448 in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x00fccd65 in gtk_menu_item_toggle_size_allocate () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x00fa3e63 in gtk_image_menu_item_get_type () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x00529b65 in g_cclosure_marshal_VOID__BOXED () from /usr/lib/libgobject-2.0.so.0
#24 0x0051d5a5 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#25 0x0051dbd8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#26 0x0052be69 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#27 0x0052d850 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#28 0x0053047f in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#29 0x0100945d in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#30 0x010097f9 in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x010a2448 in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x00fcb1c8 in gtk_menu_bar_get_pack_direction () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x00529b65 in g_cclosure_marshal_VOID__BOXED () from /usr/lib/libgobject-2.0.so.0
#34 0x0051d5a5 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#35 0x0051dbd8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#36 0x0052be69 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#37 0x0052d850 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#38 0x0053047f in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#39 0x0100945d in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#40 0x010097f9 in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#41 0x010a2448 in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#42 0x0109e65f in gtk_vbox_new () from /usr/lib/libgtk-x11-2.0.so.0
#43 0x00529b65 in g_cclosure_marshal_VOID__BOXED () from /usr/lib/libgobject-2.0.so.0
#44 0x0051d5a5 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#45 0x0051dbd8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#46 0x0052be69 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#47 0x0052d850 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#48 0x0053047f in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#49 0x0100945d in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#50 0x010097f9 in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#51 0x010a2448 in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#52 0x010b2759 in gtk_window_reshow_with_initial_size () from /usr/lib/libgtk-x11-2.0.so.0
#53 0x00529b65 in g_cclosure_marshal_VOID__BOXED () from /usr/lib/libgobject-2.0.so.0
#54 0x0051d5a5 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#55 0x0051dbd8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#56 0x0052be69 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#57 0x0052d850 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#58 0x0053047f in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#59 0x0100945d in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#60 0x010097f9 in gtk_size_group_remove_widget () from /usr/lib/libgtk-x11-2.0.so.0
#61 0x010a2448 in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#62 0x010b3900 in gtk_window_move () from /usr/lib/libgtk-x11-2.0.so.0
#63 0x010b480a in gtk_window_get_position () from /usr/lib/libgtk-x11-2.0.so.0
#64 0x00529303 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#65 0x0051d5a5 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#66 0x0051dbd8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#67 0x0052be69 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#68 0x0052d850 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#69 0x0052dbc3 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#70 0x010a93f6 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
#71 0x0805e8d4 in ev_application_open_window ()
#72 0x08079d97 in main ()
(gdb)


Version-Release number of selected component (if applicable):
fontconfig-2.3.92-1

How reproducible:
Always

Steps to Reproduce:
...

Additional info:
Comment 1 Ivan Gyurdiev 2005-11-08 01:46:02 EST
This bug is caused by not running fc-cache post install/uninstall. The reason is
that currently random scripts will refuse to work on my system, so I've
installed a lot of things with --noscripts (80% of all post-scripts will fail
with status 255, and I have no idea why).

Close bug if you think it should be closed, although it seems like the library
still shouldn't crash...

Note You need to log in before you can comment on or make changes to this bug.