This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 172716 - Scanning for updates to ~/.eclipse plugins not possible
Scanning for updates to ~/.eclipse plugins not possible
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-08 11:57 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 12:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stack trace from updating plugins in homedir (2.91 KB, text/plain)
2006-01-04 16:04 EST, Ben Konrath
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 90630 None None None Never

  None (edit)
Description Enrico Scholz 2005-11-08 11:57:10 EST
Description of problem:

| Help -> Software Updates -> Find and Install... 
| -> Search for updates of the currently isntalled features

is grayed out and can not be executed. Same operation worked with the version
shipped with FC4 fine but not with the recent update.



Version-Release number of selected component (if applicable):

eclipse-platform-3.1.1-1jpp_1fc.FC4.4


How reproducible:

100%


Additional info:

Additional features (e.g. visual editor, SVN plugin) are installed
Comment 1 Andrew Overholt 2005-11-08 12:12:56 EST
I discussed this with Ivan F. Martinez via private mail last week (before the
update went from updates-testing to updates-released).  He determined that each
package must be scanned for updates individually but that the actual updates
work.  Note that this only applies to updates of plugins that are in your home
directory (~/.eclipse) and not those installed system-wide.

I realize that the patch we have now is not perfect, but work with upstream and
the Debian maintainers is ongoing and I didn't want to stall on the 3.1.1 -> FC4
update to wait for this functionality to be perfect.
Comment 2 Andrew Overholt 2005-12-05 16:44:51 EST
I just tried out some RPMs built with Ben's latest patch and I can successfully
scan for updates for things I have installed in my home directory's update site.
 I installed an older version of Subclipse (uncheck the "latest version only"
checkbox) and then scan for an update and install it.  I got a
ConcurrentModificationException at one point, but that's a Classpath error (I
think it might even be fixed in newer releases) and not something to do with this.

Nice work, Ben!
Comment 3 Andrew Overholt 2005-12-08 10:23:09 EST
I've built packages for both rawhide (eclipse-3.1.1-1jpp_9fc) and FC4
(eclipse-3.1.1-1jpp_1fc.FC4.8 ... will appear in updates-testing at some point
today) that contain this fix.  When you get a chance, please test these to see
if they fix this problem.  Thanks.
Comment 4 Ben Konrath 2006-01-04 14:59:14 EST
Confirming this is fixed in updates-testing with
eclipse-platform-3.1.1-1jpp_1fc.FC4.11.

I will close the bug when the patch is applied upstream.
Comment 5 Ben Konrath 2006-01-04 16:04:54 EST
Created attachment 122780 [details]
stack trace from updating plugins in homedir

I just noticed that updating a plugin that is installed in your homedir gives
the attached stack trace.

Steps to reproduce:

 1) install an eariler version of subclipse (not the latest version) with the  

    update manager
 2) do Software Updates -> Find and Install to install the latest subclipse
 3) you will get the following error:

"Unable to complete action for feature "Subclipse" due to errors.
 [java.util.ConcurrentModificationException]"

 4) look at the log file and notice the attached stack trace

To ensure that the plugin is installed, you must do Software Updates -> Find
and Install again to finish the installation. 

This gcc bug might be the culprit:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=24632
Comment 6 Andrew Overholt 2006-02-03 11:15:51 EST
Any news here, Ben?  Does this still happen with the latest rawhide gcc & eclipse?
Comment 7 Ben Konrath 2006-10-04 12:37:21 EDT
(In reply to comment #6)
> Any news here, Ben?  Does this still happen with the latest rawhide gcc & eclipse?

This is fixed with the latest packages:

eclipse-sdk-3.2.1-4.fc6
gcc-java-4.1.1-28

Closing Bug.

Note You need to log in before you can comment on or make changes to this bug.