Bug 17276 - PCMCIA 3Com Modem 3CXM756 not recognized
PCMCIA 3Com Modem 3CXM756 not recognized
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-06 05:31 EDT by Robert (Roger) Stelmack
Modified: 2007-04-18 12:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert (Roger) Stelmack 2000-09-06 05:31:18 EDT
Problem description:
-------------------
On a DELL Latitude Cpi-A366XT Laptop with Red Hat 6.2 installed under the FAT32 file system with WIN/98 and Linux both operational, I 
cannot get the modem configured or recognized with Linux (WIN/95 is OK). I replaced the PCMCIA WINMODEM card (3Com Model 
3CCFEM656 10/100 LAN+56K Modem) with a new 3Com card (3Com Model 3CXM756) claimed by 3Com to be Linux compatible. Also added 
a 
DELL/3Com Fast Ethernet 10/100 Base-TX (Model - 3CCFE575CT-D) to retain the features of the removed WINMODEM card. Details of 
PCMCIA interface and cards are below.  Still the modem in not recognized by Linux.

I have not reinstalled or changed the Red Hat 6.2 Linux system. I have read many HOWTO's, but none have assisted with my problem.

Question:
--------
Are there some commands, other than the ones detailed below, that would help gather information and allow me to locate and text the 
modem? 
I would like to understand modem configuration with PCMCIA without the blanket -- reinstall the software. If this is not possible, should I just 
reinstall Red Hat 6.2? Can you suggest more places for information?



Results of typing "lsmod" as root:
---------------------------------

Module      Used by
serial_cs   0 (unused)
3c757_cb    1
cb_enabler  2 [3c575_cb]
ds          2 [serial_cs cb_enabler]
i82365      2
pcmcia_core 0[serial_cs cb_enabler ds i82365]
lockd       1(autoclean)
sunrpc      1(autoclean) [lockd]
vfat        1
fat         1 [vfat]
loop        2

Results of typing "rpm -qa | grep -I pcmcia" as root:
----------------------------------------------------

kernal-pcmcia-cs-2.2.14-5.0

Results of typing "ps -ef | grep cradmgr" as root:
-------------------------------------------------

/sbin/cardmgr

DELL BIOS Details (and Windows 95 information):
----------------------------------------------

DELL Latitude Cpi-A366XT Laptop
Pentium II-366
BIOS ver. A05
128MB System Memory
Video Memory 2.5MB
Cache 256K
Disk 6.495GB
Docking Ethernet - Enabled
Docking IRQ - Optimized
Docking Status - Undocked
Universal Connection - Enabled
Serial Port - COM1
Infrared Data Port - Disabled
Parallel Mode - ECP
Audio Mode - Full Duplex
Pointing Device - PS/2 Mouse
External Hot Key - Scroll Lock

PCMCIA (memory 08002000-08002FFF) Texas Instruments PCI-1225 Cardbus Controls:
Device Manager
Port - COM2
Max - 11520
8 bit, no parity, 1 stop bit
Uses FIFO buffer (16550 UART)
Driver:
C:\windows\system\serial.vxd
C:\windows\system\vmm32.vxd
C:\windows\3com\mdm3c756.ini
I/O - 02F8-02FF
IRQ - 03
Cards:
3Com Megahertz Modem
56K Global GSM & Cellular Modem PC Card
Model - 3CXM756
FCC  Reg - 4X2USA-33602-MM-E
IRQ - 11
Windows Memory 08001000-0801FFF

DELL/3Com Fast Ethernet 10/100 Base-TX
Model - 3CCFE575CT-D
P/N - 16-0488-000 rev A
SN - 6ZE12F33E7
IRQ - 11
Windows Memory 08000000-0800FFF
Comment 1 Michael Fulbright 2000-09-07 16:27:03 EDT
This is not an installer issue - assigned to the rp3 component.
Comment 2 Nalin Dahyabhai 2000-09-07 16:43:17 EDT
Because kudzu, the hardware detection program, is run before PCMCIA services are
initialized, it can not detect your modem.

Your hardware settings appear to be perfectly normal for a modem on /dev/ttyS1:
I/O - 02F8-02FF
IRQ - 03

Does rp3-config not detect it properly?
Comment 3 Robert (Roger) Stelmack 2000-09-09 14:39:42 EDT
That is correct -- rp3-config does not detect it. It asks to manually configure and I don't know what to configure it to.
Comment 4 Nalin Dahyabhai 2000-09-12 14:43:20 EDT
Try selecting "/dev/ttyS1" as your modem device.  This device is usually
configured to the values you've listed.
Comment 5 Robert (Roger) Stelmack 2000-09-13 13:30:33 EDT
Used kppp Configuration from Gnome environment.
Set Device:
Device -- /dev/ttys1
Flow Control -- CRTSCTS
Line Termination -- CR
Connection Speed -- 57600
Use -- lock file
Time out -- 60 seconds
Then under MODEM used QUERY MODEM and got "Sorry, the Modem does not respond"

Also, tried connection with same results.

Is there some command, log file, or anything I can try and send results to you to help. I'm not stupid, just not as familiar with Linux as I would 
like to be. Please teach me.
Comment 6 James Hickie 2000-10-06 14:51:41 EDT
Hi -

A random selection of data to contribute to the melting pot:

I have what looks like a similar problem with different hardware.  (AJP
(rebadged Kapok) 2100; 128MB PII400,  D-Link DMF560TX Ethernet/Modem - other
details below).

The message returned:

WvDial: Internet dialer version 1.41
Initializing modem.
Sending: ATZ
Modem not responding.
ERROR: Unable to initialize modem

DIALING FINISHED

If our problems are related, I doubt that a re-install is the answer.  I also
doubt that the problem has anything to do with the modem itself - I'm fairly
convinced this is to do with the pcmcia handling code - possibly interrupts are
being handled differently, now?

It started occuring exactly when I upgraded RHL6.0 to use kernel-2.2.14.
It seems that PCMCIA card services suddenly stopped talking to the serial device
on my network/modem combo card.  Or stopped talking to the kernel properly - I'm
not certain which.
I performed no other upgrades concurrently.

A clean roll-back to the previous kernel fixed the problem.
Booting my own build of linux 2.2.14 with IPSEC patches (FreeS/WAN) on a second
(otherwise identical) root partition also resulted in a successful recognition.
Unfortunately, I don't have details of those builds to hand.  If I can dig them
out I'll post them - they just show that it is possible to get the card working
with kernel 2.2.14.

My PCMCIA modem has not worked ever since (this is about a year), regardless of
the various redhat upgrades I have applied.  It still works on Win98/Win2K.  My
guess is that it is a PCMCIA-CS issue, rather than kernel or rp3.  One day, I'll
try an old card services with a modern kernel, and see if this helps.

I have tried many different builds and configurations without joy.
The serial port is recognised and a serial start for ttyS2 is executed, but the
modem is not recognised when anything tries to talk to it.

[root@localhost tmp]# uname -a
Linux localhost.localdomain 2.2.16-3 #1 Mon Jun 19 19:11:44 EDT 2000 i686
unknown
[root@localhost tmp]# rpm -qa | grep kernel
kernel-utils-2.2.16-3
kernel-2.2.16-3
kernelcfg-0.5-5
kernel-ibcs-2.2.16-3
kernel-doc-2.2.16-3
kernel-headers-2.2.16-3
kernel-BOOT-2.2.16-3
[root@localhost tmp]# date
Fri Oct  6 18:03:37 GMT 2000

Statserial continually shows exactly { DTR, DSR, CTS, RTS } high in the initial
state.
As the client tries to open the modem. (regardless of whether rp3, kppp, or
wvdial itself is used), DSR and CTS drop momentarily.
RI remains low when I dial the modem (but I have not at this point managed to
configure any modem registers.  I don't think C has to be non zero for RI to be
raised?)  I can configure dial-back successfully under 2K.
These things imply that the device drivers are there, but are not talking to the
hardware correctly.

minicom fails to talk to the modem on this port when run as root. (Successfully
talks to an external modem on ttyS0, though, when I plug that in).

[root@localhost build]# statserial /dev/ttyS2	# idle
Device: /dev/ttyS2

Signal  Pin  Pin  Direction  Status  Full
Name    (25) (9)  (computer)         Name
-----   ---  ---  ---------  ------  -----
FG       1    -      -           -   Frame Ground
TxD      2    3      out         -   Transmit Data
RxD      3    2      in          -   Receive  Data
RTS      4    7      out         1   Request To Send
CTS      5    8      in          1   Clear To Send
DSR      6    6      in          1   Data Set Ready
GND      7    5      -           -   Signal Ground
DCD      8    1      in          0   Data Carrier Detect
DTR     20    4      out         1   Data Terminal Ready
RI      22    9      in          0   Ring Indicator


I'm not sure whether the modem and network should be sharing an IRQ - the
following shows that they are trying to share IRQ3.  Using setserial to set IRQ
to 0 on that device does not fix the problem. Looking through messages, the card
sometimes gets irq 9 - for both eth and tty - this may be when I have another
card in.  It still doesn't work!

tail /var/log/messages
Oct  6 15:47:06 localhost cardmgr[455]: initializing socket 1
Oct  6 15:47:06 localhost cardmgr[455]: socket 1: D-Link DMF560TX Ethernet/Modem
Oct  6 15:47:07 localhost cardmgr[455]: executing: 'modprobe 8390'
Oct  6 15:47:07 localhost cardmgr[455]: executing: 'modprobe pcnet_cs'
Oct  6 15:47:07 localhost cardmgr[455]: executing: 'modprobe serial_cs'
Oct  6 15:47:07 localhost kernel: eth0: NE2000 Compatible: io 0x300, irq 3,
hw_addr 00:E0:98:08:7A:41 
Oct  6 15:47:07 localhost kernel: tty02 at 0x0af8 (irq = 3) is a 16450 
Oct  6 15:47:07 localhost cardmgr[455]: executing: './network start eth0'
Oct  6 15:47:07 localhost cardmgr[455]: executing: './serial start ttyS2'
Oct  6 15:47:08 localhost kernel: eth0: found link beat 

# Let's see about thaose IO/interrupt settings. I presume serial(set) means that
this range is reserved?

[root@localhost /proc]# cat ioports 
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial(auto)
0300-031f : pcnet_cs
0376-0376 : ide1
0378-037a : parport0
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
0778-077a : parport0
0af8-0aff : serial(set)
1100-1107 : ide0
1108-110f : ide1
3100-31ff : ESS Maestro 2E
[root@localhost /proc]#  

# pcnet_cs seems to have happliy grabbed 3...
 
[root@localhost /proc]# cat interrupts 
           CPU0       
  0:    4338286          XT-PIC  timer
  1:      89256          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  3:         11          XT-PIC  pcnet_cs
  4:    3557668          XT-PIC  serial
  5:         29          XT-PIC  ESS Maestro 2E
  8:          2          XT-PIC  rtc
 12:     438496          XT-PIC  PS/2 Mouse
 13:          1          XT-PIC  fpu
 14:    2836270          XT-PIC  ide0
 15:   330575          XT-PIC  ide1
NMI:          0
[root@localhost /proc]# 

# ttyS0 and ttyS1 exist on this motherboard, but there is only one
presentation.  Having IRQ3  shared between the unusable ttyS1 and ttyS2 on the
pccard shouldn't matter, should it?

[root@localhost /proc]# cat tty/driver/serial 
serinfo:1.0 driver:4.27
0: uart:16550A port:3F8 irq:4 baud:115200 tx:1621266 rx:26981230 oe:2076
RTS|CTS|DTR|DSR|CD
1: uart:16550A port:2F8 irq:3 tx:0 rx:0 
2: uart:16450 port:AF8 irq:3 baud:9600 tx:1 rx:0 
3: uart:unknown port:2E8 irq:3
4: uart:unknown port:1A0 irq:9
5: uart:unknown port:1A8 irq:9
6: uart:unknown port:1B0 irq:9
7: uart:unknown port:1B8 irq:9
8: uart:unknown port:2A0 irq:5
9: uart:unknown port:2A8 irq:5
10: uart:unknown port:2B0 irq:5
11: uart:unknown port:2B8 irq:5
12: uart:unknown port:330 irq:4
13: uart:unknown port:338 irq:4
14: uart:unknown port:0 irq:0
15: uart:unknown port:0 irq:0
16: uart:unknown port:100 irq:12
17: uart:unknown port:108 irq:12
18: uart:unknown port:110 irq:12
19: uart:unknown port:118 irq:12
20: uart:unknown port:120 irq:12
21: uart:unknown port:128 irq:12
22: uart:unknown port:130 irq:12
23: uart:unknown port:138 irq:12
24: uart:unknown port:140 irq:12
25: uart:unknown port:148 irq:12
26: uart:unknown port:150 irq:12
27: uart:unknown port:158 irq:12
28: uart:unknown port:160 irq:12
29: uart:unknown port:168 irq:12
30: uart:unknown port:170 irq:12
31: uart:unknown port:178 irq:12

# device files are correctly created:

[root@localhost /proc]# grep serial tty/drivers 
serial               /dev/cua        5   64-95 serial:callout
serial               /dev/ttyS       4   64-95 serial

[root@localhost /proc]# ls -l /dev/ttyS*
crw-------    1 james    tty        4,  64 Oct  6 17:54 /dev/ttyS0
crw-------    1 root     tty        4,  65 May  5  1998 /dev/ttyS1
crw-------    1 root     tty        4,  66 Oct  6 17:01 /dev/ttyS2
crw-------    1 root     tty        4,  67 May  5  1998 /dev/ttyS3



#  What's my system consist of?

[root@localhost build]# cat /proc/pci 
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel 440BX - 82443BX Host (rev 3).
      Medium devsel.  Master Capable.  Latency=32.  
      Prefetchable 32 bit memory at 0xa0000000 [0xa0000008].
  Bus  0, device   1, function  0:
    PCI bridge: Intel 440BX - 82443BX AGP (rev 3).
      Medium devsel.  Master Capable.  No bursts.  Min Gnt=136.
  Bus  0, device   7, function  0:
    Bridge: Intel 82371AB PIIX4 ISA (rev 2).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.  
  Bus  0, device   7, function  1:
    IDE interface: Intel 82371AB PIIX4 IDE (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable. 
Latency=32.        I/O at 0x1100 [0x1101].
  Bus  0, device   7, function  2:
    USB Controller: Intel 82371AB PIIX4 USB (rev 1).
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable. 
Latency=240.  
      I/O at 0xf300 [0xf301].
  Bus  0, device   7, function  3:
    Bridge: Intel 82371AB PIIX4 ACPI (rev 2).
      Medium devsel.  Fast back-to-back capable.  
  Bus  0, device  10, function  0:
    CardBus bridge: Texas Instruments Unknown device (rev 1).
      Vendor id=104c. Device id=ac1c.
      Medium devsel.  Master Capable.  Latency=168.  Min Gnt=192.Max Lat=7.
  Bus  0, device  10, function  1:
    CardBus bridge: Texas Instruments Unknown device (rev 1).
      Vendor id=104c. Device id=ac1c.
      Medium devsel.  Master Capable.  Latency=168.  Min Gnt=192.Max Lat=7.
  Bus  0, device  13, function  0:
    FireWire (IEEE 1394): Texas Instruments Unknown device (rev 1).
      Vendor id=104c. Device id=8009.
      Medium devsel.  IRQ 10.  Master Capable.  No bursts.  Min Gnt=3.Max
Lat=4.      Non-prefetchable 32 bit memory at 0xffefb800 [0xffefb800].
      Non-prefetchable 32 bit memory at 0xffefc000 [0xffefc000].
  Bus  0, device  16, function  0:
    Multimedia audio controller: Unknown vendor Unknown device (rev 16).
      Vendor id=125d. Device id=1978.
      Medium devsel.  Fast back-to-back capable.  IRQ 5.  Master Capable. 
Latency=128.  Min Gnt=2.Max Lat=24.
      I/O at 0x3100 [0x3101].
  Bus  1, device   0, function  0:
    VGA compatible controller: ATI Unknown device (rev 220).
      Vendor id=1002. Device id=4c42.
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable.  No
bursts.  Min Gnt=8.
      Non-prefetchable 32 bit memory at 0xd8000000 [0xd8000000].
      I/O at 0x8000 [0x8001].
      Non-prefetchable 32 bit memory at 0xd9000000 [0xd9000000].
[root@localhost build]# 
Comment 7 Nalin Dahyabhai 2000-10-06 15:20:22 EDT
Given that, I'm inclined to think that it *is* a problem in the card services
driver.  Interrupt assignments can be customized in /etc/pcmcia/config.opts, but
I suspect you already knew that.  In that case, I'll have to pass this one to a
kernel developer.
Comment 8 James Hickie 2000-10-06 21:08:13 EDT
# Thanks!
# I forgot to mention that I had tried excluding IRQ 3 like this:

# First built-in serial port
exclude irq 4
# Second built-in serial port
exclude irq 3
# First built-in parallel port
exclude irq 7

# *That* was why pccard_cs was forced to int #9!

[root@localhost /proc]# cat /proc/interrupts 
           CPU0       
  0:    6787644          XT-PIC  timer
  1:     103008          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  4:    3595933          XT-PIC  serial
  5:         29          XT-PIC  ESS Maestro 2E
  8:          2          XT-PIC  rtc
  9:          8          XT-PIC  pcnet_cs
 12:     499474          XT-PIC  PS/2 Mouse
 13:          1          XT-PIC  fpu
 14:    4259748          XT-PIC  ide0
 15:     430400          XT-PIC  ide1
NMI:          0

# And guess what - it still didn't work! (in exactly the same way)

I had run round in circles so much with this, I'd let go of engineering practice
completely :-(

J.
Comment 9 David Hinds 2000-11-21 21:35:31 EST
In the first case, I suspect an interrupt conflict.  Try excluding irq 3 in
/etc/pcmcia/config.opts; alternatively, try saying "setserial /dev/modem irq 0"
to see if that improves things at all.

The DMF560 card does not work with IO ports > 0x3ff.  As a quick fix, exclude
the high IO port ranges in /etc/pcmcia/config.opts.  The latest PCMCIA drivers
use a different IO port allocation algorithm that prefers to place cards below
the 0x400 boundary if at all possible.

-- Dave
Comment 10 Stephen Haffly 2006-04-23 23:26:04 EDT
Apparently, time has not improved the situation.  I am running Fedora Core 5
with KV 2.6.16-1.2096_FC5, i686 athlon i386 GNU/Linux.

I have recently purchased a Zonet ZFM5600CF V.92 modem card.  It will not work,
even though I tried excluding irq3 in case it was assigned to the built-in lame
modem that I have not been able to get to work either.

cat /proc/interrupts shows IRQ5 as being XT-PIC yenta, ALI 5451.  I believe
yenta to be the card manager.

There is no option in the BIOS to disable the built-in modem just as there are
no options related to the cardbus/pcmcia slots.

I can see the modem listed when I use the hwbrowser.  It is listed as INTEL CORP
V92 MODEM AT-MD56XX 5.41.  However, I cannot find it no matter which device I
try in KPPP's list.  System-config.network 1.3.30 attempts to find a modem but
reports that no modem was found on my system.

I am very interested in getting this to work as we will be moving this summer,
and will only have access to dial-up services for two to three months.

Stephen
Comment 11 Bill Nottingham 2006-08-07 13:54:02 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 12 Bill Nottingham 2006-10-18 10:58:24 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.