Bug 172780 - broken dependency: apr-devel requires gcc 3.4.3
broken dependency: apr-devel requires gcc 3.4.3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: apr (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 12:07 EST by Jim Faulkner
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 10:49:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Faulkner 2005-11-09 12:07:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050929 Firefox/1.0.7

Description of problem:

apr-devel, as well as a couple of other packages, depend on gcc 3.4.3, which is no longer available in Enterprise 4 Update 2:

[root@rt i386]# rpmquery --requires apr-devel
/bin/sh
apr = 0.9.4-24.5
gcc = 3.4.3
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[root@rt i386]#
[root@rt i386]# rpm -q gcc
gcc-3.4.4-2

RedHat's version of RPM and up2date do not seem to have a problem with this broken dependency, however third party tools such as apt-rpm do have problems with this:
[root@rt i386]# apt-get -s upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  apr-devel: Depends: gcc (= 3.4.3) but 3.4.4-2 is installed
  gcc4-c++: Depends: libstdc++ (= 3.4.3) but 3.4.4-2 is installed
            Depends: libstdc++-devel (= 3.4.3) but 3.4.4-2 is installed
  libtool: Depends: gcc (= 3.4.3) but 3.4.4-2 is installed
E: Unmet dependencies. Try using --fix-broken.
[root@rt i386]#

As you can see, the other packages which incorrectly depend on gcc 3.4.3 are libtool and gcc4-c++.


Version-Release number of selected component (if applicable):
apr-devel-0.9.4-24.5

How reproducible:
Always

Steps to Reproduce:
1.rpmquery --requires apr-devel
2.rpm -q gcc
3.


Expected Results:  
No up-to-date package should require an outdated version of another package.


Additional info:
Comment 1 Joe Orton 2005-11-23 10:49:36 EST
Thanks for the report.

The gcc package Provides: gcc = 3.4.3 so there is not a packaging problem here.

# rpm -q --provides gcc
gcc = 3.4.3-26
gcc34
gcc = 3.4.4-2

if and when apr is rebuilt for a future update, it will pick up a dependency on
the new version of gcc, but until then, there is no functional problem.

Note You need to log in before you can comment on or make changes to this bug.