Bug 172799 - rpm -F doesn't install dependancies
rpm -F doesn't install dependancies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 16:15 EST by Charles C. Van Tilburg
Modified: 2014-01-21 17:53 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 17:10:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles C. Van Tilburg 2005-11-09 16:15:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
an attempted rpm -Fvh resulted in an error message when the dependencies 
it was complaining about were sitting in the same directory!

In this case, the freshen was run on eclipse3.1.1-1jpp_1fc.FC4.4, and the
dependencies were:

libswt3-gtk2
lucene
lucene-demo
eclipse-rcp

I had to manually install libswt3-gtk2, lucene, and lucene-demo.  Then,
the eclipse-rcp package had to be installed --nodeps --force because of
its dependancy on the new eclipse!

I do not believe this is reasonable behaviour.

Version-Release number of selected component (if applicable):
rpm-4.4.1-22

How reproducible:
Always

Steps to Reproduce:
1. rpm -Fvh on new eclipse with all relevant files sitting in the same dir
2.
3.
  

Actual Results:  # rpm -Fvh eclipse*
error: Failed dependencies:
        eclipse-rcp = 1:3.1.1-1jpp_1fc.FC4.4 is needed by
eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
        libswt3-gtk2 = 1:3.1.1-1jpp_1fc.FC4.4 is needed by
eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
        lucene is needed by eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386
        lucene-demo is needed by eclipse-platform-3.1.1-1jpp_1fc.FC4.4.i386



Expected Results:  update intelligently: see the dependancies sitting in the directory and 
add them as install dependancies automatically.  

I don't believe the user/sysadmin should have to exert manual effort in 
this case.

Additional info:
Comment 1 Paul Nasrat 2005-11-09 17:10:03 EST
rpm is not a depsolver, freshen has never been pulled in extra packages.

Use yum install eclipse-rcp
Comment 2 Charles C. Van Tilburg 2005-11-09 17:54:52 EST
Negative.  I will not use yum.

I am talking about a freshen DEPENDANCY, not an 'extra package'.

I strongly suggest you re-read what I wrote more carefully.  There are 
problems here with the freshen option that could be fixed for the benefit
of many, if not all who use the utility.

Furthermore, I believe this is a bug and if you do not, you are wrong.  
I don't care if 'it never did that before', I think it should!

Your attitude about maintaining and improving a Red Hat authored tool 
leads me to believe I should explore moving to another distro and deleting
all Red Hat authored content.
Comment 3 Paul Nasrat 2005-11-09 18:30:04 EST
Yum is the recommended software installation tool for Fedora, it sits on top of
rpm to provide dependency solving, etc.  If you choose not to use it, then you
will have to perform some tasks with more manual intervention.  It is not rpm's
job to go poking around in the current directory to see if you have more
packages than you specified on the command line.  The tool exists so that the
sysadmin does not have to expend extra effort.

There are no current plans to change freshen behaviour to deal with new
dependencies, should you wish to argue for a feature the correct place is
rpm-devel-list.  
Comment 4 Charles C. Van Tilburg 2005-11-09 18:37:08 EST
Negative.  Yum is 'Yellowdog Updater Modified'... it is a network retrieval
tool used for tracking purposes.  

RPM is a 'Package Manager' that should have the capabilities I describe as
part of the FRESHEN option.

Yum is completely unnecessary and superfluous to rpm, if rpm worked properly,
in the context in which I am using it.

Please explain how 'rpm -Fvh *.rpm' in a mirrored RPM repository could fail 
to find the package... AS A DEPENDANCY?!

This is a bug.  I will never agree with you.  I will not debate with an idiot.
Comment 5 Michael Jennings (KainX) 2005-11-09 19:34:52 EST
Unfortunately, he may have to because it's his job.

Hopefully after you make it through puberty, someone will help you realize that,
no matter how smart you think you are, someone disagreeing with you does not
make that person an idiot.
Comment 6 Charles C. Van Tilburg 2005-11-09 20:07:51 EST
You have much to learn.
Comment 7 Seth Vidal 2005-11-09 21:10:42 EST
This is too funny.

Paul, Add a rpm --magically-fulfill option. But just make it a popt alias to rpm
--nodeps.

And I think a reference to yum farkas-mode is in order, too.


Note You need to log in before you can comment on or make changes to this bug.