Bug 172812 - Admin Server build process overwrites ANT_HOME
Admin Server build process overwrites ANT_HOME
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2005-11-09 18:10 EST by Nathan Kinder
Modified: 2015-12-07 11:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:51:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS DIffs (1.60 KB, patch)
2005-11-09 18:10 EST, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nathan Kinder 2005-11-09 18:10:56 EST
Admin Server's build process sets ANT_HOME regardless of setting the
INTERNAL_BUILD or GET_ANT_FROM_PATH flags.  This can cause build problems when
building the Admin Server console jarfiles.  The logic should be to only set
ANT_HOME if INTERNAL_BUILD is set and GET_ANT_FROM_PATH is not set.

I also noticed that we are packaging the ant jarfiles and the jss xpclass.jar
file with the Console, which we shouldn't be doing.
Comment 1 Nathan Kinder 2005-11-09 18:10:56 EST
Created attachment 120862 [details]
CVS DIffs
Comment 2 Nathan Kinder 2005-11-09 18:22:42 EST
Checked into adminserver (HEAD).  Reviewed by Rich.

Checking in components.mk;
/cvs/dirsec/adminserver/components.mk,v  <--  components.mk
new revision: 1.40; previous revision: 1.39
done
Checking in base/Makefile;
/cvs/dirsec/adminserver/base/Makefile,v  <--  Makefile
new revision: 1.15; previous revision: 1.14
done
Comment 3 Nathan Kinder 2007-12-14 15:29:28 EST
These changes no longer apply since we've moved to autotools for the adminserver
build system.  Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.