Bug 172823 - [FC4] update to 2.3.6 needed to replace fc3 update on system upgrade to fc4
[FC4] update to 2.3.6 needed to replace fc3 update on system upgrade to fc4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 173167 176510 (view as bug list)
Depends On:
Blocks: 171491
  Show dependency treegraph
 
Reported: 2005-11-09 20:53 EST by Charles R. Anderson
Modified: 2016-11-24 10:43 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.3.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 15:27:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full yum debug output (9.38 KB, text/plain)
2005-11-09 20:53 EST, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2005-11-09 20:53:14 EST
Description of problem:

After yum updating to glibc-2.3.6-0.fc3.1, followed by a system upgrade
to FC4, now yum breaks when trying to install e.g. glibc-devel because
the FC3 glibc update is newer than any available FC4 glibc.

Version-Release number of selected component (if applicable):

2.3.5-10.3

How reproducible:

always

Steps to Reproduce:
1. Install FC3 without any Development Tools, or yum groupremove 'Development
Tools'.
2. yum update to 2005/11/09.
3. Upgrade system to FC4 using anaconda installer.
3. Attempt to install glibc-devel:  yum install glibc-devel
  
Actual results:

# yum -d 9 install glibc-devel
[...]
Error: Missing Dependency: glibc-headers = 2.3.5-10.3 is needed by package
glibc-devel
Error: Missing Dependency: glibc = 2.3.6-0.fc3.1 is needed by package glibc-headers
Error: glibc-common conflicts with glibc < 2.3.6
Error: Missing Dependency: glibc-common = 2.3.5-10.3 is needed by package glibc


Expected results:

Updates for older distros should not be released that have a higher EVR than
updates available for later distros.

Additional info:

yum-2.4.0-0.fc4
Comment 1 Charles R. Anderson 2005-11-09 20:53:14 EST
Created attachment 120868 [details]
Full yum debug output
Comment 2 Jakub Jelinek 2005-11-14 16:25:22 EST
*** Bug 173167 has been marked as a duplicate of this bug. ***
Comment 3 Ed Swierk 2005-11-14 16:36:03 EST
An updated install CD set for FC4 is also needed, containing a glibc that can
replace the newest FC3 glibc.
Comment 4 Jakub Jelinek 2005-11-14 16:41:08 EST
Fedora Core CDs are released just once, so the request in #3 can't be satisfied.
The FC3 update glibc provides all symbols FC4 glibc provides, so until a newer
FC4 glibc is released (roughly in a month or so), you can use the FC3 glibc
instead of FC4 one, or force "downgrade" to the FC4 update glibc.
Comment 5 Charles R. Anderson 2005-11-14 17:00:22 EST
Did someone overlook the fact that the FC4 yum repositories would be in an
unusable state for these users until the FC4 glibc update is released, unless
manual package downgrades using rpm are done?  If so, will this be considered in
the future as to not cause this situation?  Thanks.
Comment 6 Jakub Jelinek 2005-12-23 15:56:48 EST
*** Bug 176510 has been marked as a duplicate of this bug. ***
Comment 7 Curtis Doty 2006-01-11 02:16:51 EST
For now,

# rpm -Uvh --oldpackage glibc-2.3.5-10.3.i686.rpm glibc-common-2.3.5-10.3.i386.rpm
Preparing...                ########################################### [100%]
   1:glibc-common           ########################################### [ 50%]
   2:glibc                  warning: /etc/localtime created as /etc/localtime.rpmnew
########################################### [100%]
Stopping sshd: [  OK  ]
sleep: relocation error: /lib/libpthread.so.0: symbol errno, version
GLIBC_PRIVATE not defined in file libc.so.6 with link time reference
Starting sshd: [  OK  ]

But that really is unpretty; especially in the light of the historical record:

      release    latest
rh6.2 2.1.3  ->  2.1.3
rh7.3 2.2.5  ->  2.2.5
fc1   2.3.2  ->  2.3.2
fc3   2.3.3  -> *2.3.6* WTF?
fc4   2.3.5  ->  2.3.5
Comment 8 Jakub Jelinek 2006-03-15 15:27:30 EST
glibc-2.3.6-3 is in FC4 testing updates.

Note You need to log in before you can comment on or make changes to this bug.