This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 172843 - Mozilla freezes occasional
Mozilla freezes occasional
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 09:30 EST by Thomas Hartwig
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 05:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Hartwig 2005-11-10 09:30:05 EST
Description of problem:
Mozilla freezes occasional after a system update of . It worked absolutely well
before.

Version-Release number of selected component (if applicable):
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923
Fedora/1.7.12-1.5.1

How reproducible:
It crashes sometimes very quick, sometimes not, one page where it crashes very
fast: http://www.heise.de/newsticker/meldung/65982

Steps to Reproduce:
1. Start mozilla
2. Open: http://www.heise.de/newsticker/meldung/65982
  
Actual results:
Mozilla freezes completely.

Expected results:
No crash/freezing.


Additional info:

GDB backtrace:

Program received signal SIG33, Real-time event 33.
[Switching to Thread -1276212304 (LWP 30131)]
0xffffe410 in __kernel_vsyscall ()
(gdb) where
#0  0xffffe410 in __kernel_vsyscall ()
#1  0x42edaa1c in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7eb218b in PR_Lock () from /usr/lib/libnspr4.so
#3  0xb7eb2513 in PR_WaitCondVar () from /usr/lib/libnspr4.so
#4  0xb7a554bd in NSGetModule () from /usr/lib/mozilla-1.7.12/components/libnecko.so
#5  0xb7a55cb2 in NSGetModule () from /usr/lib/mozilla-1.7.12/components/libnecko.so
#6  0xb7eb7409 in PR_Select () from /usr/lib/libnspr4.so
#7  0x42ed8b80 in start_thread () from /lib/libpthread.so.0
#8  0x42d499ce in clone () from /lib/libc.so.6

Some package versions:
glibc-2.3.5-10.3
mozilla-1.7.12-1.5.1
mozilla-nspr-1.7.12-1.5.1
kernel-T4x-2.6.13.4-22 (a special thinkpad kernel)
Comment 1 Thomas Hartwig 2005-11-10 09:51:42 EST
It seems to be related to the special kernel I use. I tried the standard one and
it seems to work without freezing. I will talk to the kernel vendor.

Linux nautilus 2.6.13-1.1532_FC4 #1 Thu Oct 20 01:30:08 EDT 2005 i686 i686 i386
GNU/Linux

Comment 2 Thomas Hartwig 2005-11-11 05:28:56 EST
The problem seemed to be an inconsitency in the mozilla package for my
installation. I reinstalled mozilla and it works fine until now. The problem
occured even faster with a brand new kernel. Sorry for the noise.

$: rpm -V mozilla
..5..U.T    /usr/bin/mozilla
missing     /usr/lib/mozilla-1.7.12/chrome/overlayinfo/browser
missing     /usr/lib/mozilla-1.7.12/chrome/overlayinfo/browser/content
missing     /usr/lib/mozilla-1.7.12/chrome/overlayinfo/browser/skin
missing     /usr/lib/mozilla-1.7.12/chrome/overlayinfo/global
missing     /usr/lib/mozilla-1.7.12/chrome/overlayinfo/global/content
missing     /usr/lib/mozilla-1.7.12/chrome/overlayinfo/global/skin
prelink: /usr/lib/mozilla-1.7.12/xpicleanup: at least one of file's dependencies
has changed since prelinkin
g
S.?.....    /usr/lib/mozilla-1.7.12/xpicleanup
.....UG.    /usr/lib/mozilla/plugins

Note You need to log in before you can comment on or make changes to this bug.