Bug 172855 - problem with the new installonlyn plugin
problem with the new installonlyn plugin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 11:27 EST by Jason
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 16:37:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-11-10 11:27:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
I updated to yum-2.4.0-11 and now if I do a yum update kernel I get the following:

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.0 MB    00:03
developmen: ################################################## 3838/3838
Added 552 new packages, deleted 518 old in 25.99 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-devel.i686 0:2.6.14-1.1657_FC5 set to be installed
---> Package kernel.i686 0:2.6.14-1.1657_FC5 set to be installed
--> Running transaction check
Traceback (most recent call last):
 File "/usr/bin/yum", line 27, in ?
   yummain.main(sys.argv[1:])
 File "/usr/share/yum-cli/yummain.py", line 133, in main
   (result, resultmsgs) = base.buildTransaction()

File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 340, in buildTransaction

   self.plugins.run('postresolve', rescode=rescode, restring=restring)
 File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 159, in run
   func(conduitcls(self, self.base, conf, **kwargs))
 File "/usr/lib/yum-plugins/installonlyn.py", line 58, in postresolve_hook
   (curv, curr) = get_running_kernel_version_release()

File "/usr/lib/yum-plugins/installonlyn.py", line 39, in get_running_kernel_version_release

   (v, r) = ver.split("-", 1)
ValueError: need more than 1 value to unpack

According to Jeff Spaleta the problem looks like a problem with the new installonlyn plugin.

edit  /etc/yum/pluginconf.d/installonlyn.conf
change to enabled=0
fixes the problem.

Here is my uname -a (it is a custom kernel):
Linux pcjason.home.local 2.6.14extra #13 Tue Nov 8 13:54:52 CST 2005 i686 i686 i386 GNU/Linux

Thanks,
Jason




Version-Release number of selected component (if applicable):
yum-2.4.0-11

How reproducible:
Always

Steps to Reproduce:
1. install new yum
2. do a yum update kernel
3.
  

Actual Results:  I get the traceback.

Expected Results:  The kernel should have downloaded and installed.

Additional info:
Comment 1 Jef Spaleta 2005-11-10 11:34:08 EST
The problem is the custom kernel is using a custom naming scheme that the plugin
was not expecting.  I think the plugin is going to have to be a bit more robust
and when confronted with an unexpected custom versioning scheme just fail over
and disable itself.  There needs to be a check before the split is attempted, I
just can't remember of the top of my head what the correct check code should be.

-jef
Comment 2 Jeremy Katz 2005-11-10 16:37:20 EST
Fixed for -12

Note You need to log in before you can comment on or make changes to this bug.