Bug 172877 - Allows entry of empty environment variables
Summary: Allows entry of empty environment variables
Status: CLOSED DUPLICATE of bug 172866
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-httpd   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-10 19:37 UTC by Ian Chapman
Modified: 2015-03-05 01:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 15:27:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Chapman 2005-11-10 19:37:14 UTC
From Bugzilla Helper:
User-Agent: Opera/8.5 (X11; Linux x86_64; U; en)

Description of problem:
The tool allows you to enter empty environment variables for CGI scripts, this 
breaks apache's syntax, it fails to restart and an error is produced, for 
example:

SetEnv takes 1-2 arguments, an environment variable name and optional value to 
pass to CGI.


Version-Release number of selected component (if applicable):
 system-config-httpd-1.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Edit or add a virtual host.
2. Click environment tab
3. Click add, but press OK without entering anything
4. Apply the changes
5. Restart apache
  

Actual Results:  Apache fails to restart and an error is produced.

Expected Results:  The tool should not produce invalid syntax in the apache configuration file. A 
warning should be given to the user.

Additional info:

Comment 1 Phil Knirsch 2006-10-25 15:27:11 UTC

*** This bug has been marked as a duplicate of 172866 ***


Note You need to log in before you can comment on or make changes to this bug.