Bug 17290 - Rawhide supports GeForce2, but not its variants: MX, Ultra, Quadro 2 Pro, etc...
Rawhide supports GeForce2, but not its variants: MX, Ultra, Quadro 2 Pro, etc...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 18844 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-06 13:11 EDT by George Karabin
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 14:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Karabin 2000-09-06 13:11:43 EDT
Bug #16837 is resolved, now that Rawhide supports the GeForce2 chip (PCI ID
0x150 according to xc/programs/Xserver/hw/xfree86/common/xf86PciInfo.h). 

However, Rawhide is missing support for a bunch of GeForce2 variants. The
GeForce2 MX is the "value" product from Nvidia. Additionally, Rawhide does
not support the Ultra, Quadro 2 Pro, and other variants that have recently
been checked into XFree86 CVS. I would expect that the MX is going to show
up in a lot of OEM systems this fall, and a lot of people will try to
install RedHat on it. 

I think it would be a real good idea to support the MX in the next Red Hat
release (7.0 ?), and the other variants as well, if there isn't much risk.
I'm pretty sure that the change only amounts to adding a few constants for
the PCI IDs and adding the constants to a table of recognized cards.

The August CVS changelog for XFree86
(http://www.xfree86.org/pipermail/cvs-commit/2000-August.txt.gz) lists a
bunch of nvidia changes. There is at least one change in there to add
acceleration support (which you may or may not want to skip). I've attached
an excerpt from the change log showing the change descriptions that I hope
you will look at.
==========================================================================
From mvojkovi@XFree86.Org Thu, 10 Aug 2000 22:02:04 -0700 (PDT)
Date: Thu, 10 Aug 2000 22:02:04 -0700 (PDT)
From: Mark Vojkovich mvojkovi@XFree86.Org
Subject: cvs commit: XFree86

mvojkovi    00/08/10 22:02:04

  Modified:    programs/Xserver/hw/xfree86/common xf86PciInfo.h
  Log:
     Add PCI IDs for new NVIDIA cards (GeForce2 varieties)
  
  Revision  Changes    Path
  1.66      +15 -1     xc/programs/Xserver/hw/xfree86/common/xf86PciInfo.h



From mvojkovi@XFree86.Org Thu, 10 Aug 2000 22:04:08 -0700 (PDT)
Date: Thu, 10 Aug 2000 22:04:08 -0700 (PDT)
From: Mark Vojkovich mvojkovi@XFree86.Org
Subject: cvs commit: XFree86

mvojkovi    00/08/10 22:04:08

  Modified:    programs/Xserver/hw/xfree86/drivers/nv nv_driver.c nv_type.h
                        nv_xaa.c riva_tbl.h
  Log:
     Add support for GeForce2 to the NVIDIA driver.
  
  Revision  Changes    Path
  1.45      +23 -2    
xc/programs/Xserver/hw/xfree86/drivers/nv/nv_driver.c
  1.13      +7 -0      xc/programs/Xserver/hw/xfree86/drivers/nv/nv_type.h
  1.15      +3 -3      xc/programs/Xserver/hw/xfree86/drivers/nv/nv_xaa.c
  1.6       +83 -3     xc/programs/Xserver/hw/xfree86/drivers/nv/riva_tbl.h



From mvojkovi@XFree86.Org Thu, 10 Aug 2000 22:06:18 -0700 (PDT)
Date: Thu, 10 Aug 2000 22:06:18 -0700 (PDT)
From: Mark Vojkovich mvojkovi@XFree86.Org
Subject: cvs commit: XFree86

mvojkovi    00/08/10 22:06:18

  Modified:    programs/Xserver/hw/xfree86 CHANGELOG
  Log:
  
  
  Revision  Changes    Path
  3.1263    +2 -1      xc/programs/Xserver/hw/xfree86/CHANGELOG



From mvojkovi@XFree86.Org Thu, 10 Aug 2000 23:14:11 -0700 (PDT)
Date: Thu, 10 Aug 2000 23:14:11 -0700 (PDT)
From: Mark Vojkovich mvojkovi@XFree86.Org
Subject: cvs commit: XFree86

mvojkovi    00/08/10 23:14:11

  Modified:    programs/Xserver/hw/xfree86/drivers/nv nv_xaa.c
  Log:
    Accelerated line support for the NV driver.
  
  Revision  Changes    Path
  1.16      +32 -23    xc/programs/Xserver/hw/xfree86/drivers/nv/nv_xaa.c



From mvojkovi@XFree86.Org Thu, 10 Aug 2000 23:15:35 -0700 (PDT)
Date: Thu, 10 Aug 2000 23:15:35 -0700 (PDT)
From: Mark Vojkovich mvojkovi@XFree86.Org
Subject: cvs commit: XFree86

mvojkovi    00/08/10 23:15:35

  Modified:    programs/Xserver/hw/xfree86 CHANGELOG
  Log:
  
  
  Revision  Changes    Path
  3.1264    +3 -2      xc/programs/Xserver/hw/xfree86/CHANGELOG
Comment 1 Preston Brown 2001-02-26 13:55:34 EST
Mike, this is resolved in our current Rawhide XFree86, correct?
Comment 2 Preston Brown 2001-02-26 14:00:06 EST
*** Bug 18844 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2001-02-26 14:43:47 EST
Yes, I am quite sure it is.  If there is a specific card that we do not
have a PCI ID for, then someone will have to file a specific bugzilla
against that card with the full PCI ID's.  I'm closing this to rawhide.

Note You need to log in before you can comment on or make changes to this bug.