Bug 172906 - needs libcdda.so
needs libcdda.so
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-10 20:20 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 17:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PDF example that triggers error for missing libcdda.so (1.49 KB, application/octet-stream)
2005-11-10 20:20 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-11-10 20:20:25 EST
Description of problem:
evince has a dependency on /usr/lib64/gnome-vfs-2.0/modules/libcdda.so
but the rpm fails to flag if the dependency is missing.

evince dies on the attached example

Version-Release number of selected component (if applicable):
evince-0.4.0-2
gnome-vfs2-2.12.1.1-5

How reproducible:
100%

Steps to Reproduce:
1.evince crazy.dot.pdf
2.
3.
  
Actual results:
(evince:14206): libgnomevfs-WARNING **: Cannot load module
`/usr/lib64/gnome-vfs-2.0/modules/libcdda.so'
(/usr/lib64/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object file: No
such file or directory)


Expected results:
1. display the pdf
2. check dependencies during installation


Additional info:
Comment 1 John Ellson 2005-11-10 20:20:26 EST
Created attachment 120916 [details]
PDF example that triggers error for missing libcdda.so
Comment 2 Oisin C. Feeley 2006-04-28 23:20:07 EDT
Running evince on the commandline I get a similar problem with some documents:

(evince:6564): libgnomevfs-WARNING **: Cannot load module
`/usr/lib/gnome-vfs-2.0/modules/libcdda.so'
(/usr/lib/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object file: No
such file or directory)

(evince:6564): Gtk-CRITICAL **: gtk_tree_model_foreach: assertion
`GTK_IS_TREE_MODEL (model)' failed

(evince:6564): Gtk-CRITICAL **: gtk_list_store_clear: assertion
`GTK_IS_LIST_STORE (list_store)' failed

The versions are:
[ush@larry ~]$ rpm -q poppler
poppler-0.5.1-2
[ush@larry ~]$ rpm -q evince
evince-0.5.1-3

This is on an x86 platform.
Comment 3 Kristian Høgsberg 2006-09-22 17:07:09 EDT
evince has no dependencies on libcdda.so, and this looks like a gnome-vfs error.
 I can't reproduce this with recent rawhide (evince-0.6, gnome-vfs-2.16). 
Closing bug.

Note You need to log in before you can comment on or make changes to this bug.