Bug 17291 - Installed kernel fails on Duron
Summary: Installed kernel fails on Duron
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-06 17:18 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-06 17:18:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-06 17:18:26 UTC
After instalation on AMD Duron 600Mz reboot seems to load kernel and kernel
seems to fail after producing about one screen of info.  Included is:

Disabling CPUID Serial number...general protection fault: 0000

There is then what looks like a dump of the cpu registers and some other
information and it ends with:

Kernel panic: Attempted to kill the idle task!
In swapper task - not syncing

The "boot floppy" made during the instalation produces the same result on
the Duron but runs on an AMD K6-2 300Mz.

I can boot the Duron with an instal floppy coppied from the 6.2 CD using
the rescue option.  I can then mount my hard drive and find that many files
have actually been installed.

Art Sherman

Comment 1 Alan Cox 2000-09-15 17:24:24 UTC
This is fixed in the errata kernel rpm (2.2.16). If you boot via rescue as you
have done then run

wherevermyrootdiskis/sbin/chroot /wherevermyrootdiskis /bin/sh
cd /
and use rpm to install the errata kernel rpm

then all will be rather happier. The duron reused a flag for different meanings
confusing the Linux kernel that assumed the flag was cross vendor.



Note You need to log in before you can comment on or make changes to this bug.