Bug 172917 - FC4 anaconda failed to upgrade many FC3 packages
Summary: FC4 anaconda failed to upgrade many FC3 packages
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-11 09:46 UTC by Ed Swierk
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 04:24:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/upgrade.log (9.85 MB, text/plain)
2005-11-11 09:46 UTC, Ed Swierk
no flags Details

Description Ed Swierk 2005-11-11 09:46:44 UTC
I used the FC4 CD to try to upgrade my laptop which had been running FC3. 
Although the process seemed to finish normally, when I rebooted, I noticed that
many dozens of packages remained untouched by the upgrade, including the kernel
and glibc packages.

I had to upgrade the kernel and glibc packages with rpm, then use yum to grab
the remaining upgrades.

(Since I had been keeping my FC3 system relatively current with updated
packages, the installed FC3 glibc package actually had a higher version number
than the FC4 package.  Perhaps this explains anaconda's confusion?)

See the attached upgrade.log.

Comment 1 Ed Swierk 2005-11-11 09:46:47 UTC
Created attachment 120927 [details]
/root/upgrade.log

Comment 2 Jeremy Katz 2005-11-12 04:24:32 UTC
Yep, anaconda can't upgrade things to a lower version number... that's a bug in
the specific packages as they should be making sure that they keep their version
lower than the FC4 released version

Comment 3 Ed Swierk 2005-11-12 08:00:08 UTC
I'm not sure I understand how this could be a bug in the specific packages. 
What version number should an updated FC3 glibc use if it is based on 2.3.6?  It
seems sort of odd to call it 2.3.5 just to keep FC4 happy.



Note You need to log in before you can comment on or make changes to this bug.