Bug 1729329 - can only install to spin disc [NEEDINFO]
Summary: can only install to spin disc
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-11 23:45 UTC by Bob Siegfried
Modified: 2020-05-26 18:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 18:25:08 UTC
Type: Bug
vponcova: needinfo? (robtsiegfried)


Attachments (Terms of Use)
screenshot of early portion of install (Plymouth?) (5.60 MB, image/jpeg)
2019-07-11 23:45 UTC, Bob Siegfried
no flags Details

Description Bob Siegfried 2019-07-11 23:45:34 UTC
Created attachment 1589702 [details]
screenshot of early portion of install (Plymouth?)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
[ OK ] Started Show Plymouth Boot Screen.

. . .

[ OK ] Started Monitoring of LVM2ë dmeventd or progress polling.

[Failed] Failed to start LVM2 PV scan on device 8:18.

See 'systemctl status lvm2-pvscan@8:18.service' for details.

[Failed] Failed to start LVM2 PV on device 259:3.

See 'systemctl status lvm2-pvscan@259:3.service' for details.

[Failed] Failed to start LVM2 PV on device 259:2.

See 'systemctl status lvm2-pvscan@259:2.service' for details.

[Failed] Failed to start LVM2 PV on device 8:3.

See 'systemctl status lvm2-pvscan@8:3.service' for details.

[ OK ] Started udev Wait for Complete Device Initialization.

[ OK ] from here on

This system previously ran Fedora 30. I swapped out 2 spin drives for a new spin drive and an SSD because one of the old drives developed a bad sector. A pair of M.2's are also in the system. All four old components were previously operating under Fedora 30. The only way I can get the system to install and boot now is to install only on the spin drive, leaving the M.2's and the SSD unutilized.

The only other info that seems relevant is that the new spin drive constantly get set up as sda, and the SSD as sdb each time I attempt an install trying to use both drives. I have tried installs with all possible combinations of storage components. 
2.
3.

Actual results: Can only install to new spin drive, and must select for each boot


Expected results: Successful installation


Additional info: Is this an Anaconda storage device detection issue?

Comment 1 Hans de Goede 2020-03-09 10:43:04 UTC
If I understand you correctly, you did a clean re-install after replacing the disks and then after install the system will not boot correct?

This indeed sounds like an anaconda issue (it certainly is not a plymouth issue), changing component.

Comment 2 Vendula Poncova 2020-03-09 11:04:14 UTC
Please, attach all logs (including syslog) from the installation. You can find them during the installation in /tmp or on the installed system in /var/log/anaconda/. Have you tried to install Fedora 31 instead?

Comment 3 Ben Cotton 2020-04-30 20:22:13 UTC
This message is a reminder that Fedora 30 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 30 on 2020-05-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '30'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 30 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Ben Cotton 2020-05-26 18:25:08 UTC
Fedora 30 changed to end-of-life (EOL) status on 2020-05-26. Fedora 30 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.