Bug 172963 - Package fixes and cleanups for gnome-power-manager
Package fixes and cleanups for gnome-power-manager
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 12:03 EST by Matthias Saou
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 14:23:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (3.44 KB, patch)
2005-11-11 12:03 EST, Matthias Saou
no flags Details | Diff
Spec file patch (against CVS rev 1.28) (3.70 KB, patch)
2005-12-20 12:09 EST, Matthias Saou
no flags Details | Diff

  None (edit)
Description Matthias Saou 2005-11-11 12:03:23 EST
Created attachment 120951 [details]
Spec file patch
Comment 1 Matthias Saou 2005-11-11 12:03:23 EST
Suggested changes to the current 0.2.8-1 spec file :

* Fri Nov 11 2005 Matthias Saou <http://freshrpms.net/> 0.2.8.1-1
- Update to 0.2.8.1.
- Don't own entire man/man1/ directory.
- Mark dbus file as config.
- Minor cleanups.

The important fix is the man1 directory ownership. For the dbus config file,
maybe it doesn't make much sense, or maybe it would be best as
config(noreplace), I'm not sure. Same goes for the dbus services file : Should
it be marked as %config or %config(noreplace)?
Comment 2 Richard Hughes 2005-11-11 12:11:22 EST
I'm going to be releasing 0.3.0 (major update) in a few days so it might be
worth waiting and then just rolling this out for the new version.
The new version does the gconf schema stuff in a better way so that the package
actually works.

The upstream spec might need fixing too:
http://cvs.gnome.org/viewcvs/gnome-power-manager/gnome-power-manager.spec.in?rev=1.19&view=markup

Richard.
Comment 3 Matthias Saou 2005-11-11 12:50:50 EST
For the man1 directory, yes the upstream spec file needs fixing too. It could do
with more fixes and cleanups... for instance using %{buildroot} as the prefix
passed to configure is plain wrong!

I can provide the same fixes and cleanups against that spec file if you want.
Comment 4 Richard Hughes 2005-11-11 13:04:52 EST
Yes please. Commit directly to gnome CVS if you like. I think you know what you
are doing :-)
Comment 5 Richard Hughes 2005-12-09 19:05:26 EST
I've done a few of these upstream. Can you comment on the new spec file please?
Comment 6 Matthias Saou 2005-12-20 12:08:43 EST
Attached is a new spec.in patch :
- Change obsolete BuildPrereq to BuildRequires
- Enter full source URL (drawback is the 0.3 directory on ftp.gnome.org)
- Remove trailing leftover spaces
- Use -jX make flags if configured
- Don't compare strings against integers in the scriplets
- Default to 0755 mode for directories
- Don't include the generic INSTALL file

These are all very minor details, and since the real problem (man1 directory
ownership) has already been fixed, you can close this bug anytime you want ;-)
Comment 7 Matthias Saou 2005-12-20 12:09:42 EST
Created attachment 122453 [details]
Spec file patch (against CVS rev 1.28)
Comment 8 Richard Hughes 2005-12-20 14:23:29 EST
I've applied your patch to the upstream CVS, many thanks. J5/mclasen, can you
make sure that the next build of g-p-m uses the modifications in the the
upstream tarball. Many thanks. Richard.

Note You need to log in before you can comment on or make changes to this bug.