Bug 1729685 - vbox: add support for 6.0
Summary: vbox: add support for 6.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-13 14:08 UTC by jeffrey.wildman
Modified: 2020-09-11 17:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-11 17:00:00 UTC


Attachments (Terms of Use)

Description jeffrey.wildman 2019-07-13 14:08:21 UTC
Description of problem:

libvirt does not appear to support the most recent VirtualBox 6.0 API. I didn't see an existing ticket for this and am hoping this is the right place to add one.

Version-Release number of selected component (if applicable):

5.5.0

How reproducible:

always

Steps to Reproduce:

1. virsh --debug=4 -c vbox:///session

Actual results:

```
error: failed to connect to the hypervisor
error: internal error: unable to initialize VirtualBox driver API
```

Expected results:

successful connection to vbox hypervisor

Comment 1 Daniel Berrangé 2019-07-15 08:29:10 UTC
Thanks for the bug report, however, to set realistic expectations I must mention that the vbox driver doesn't have an active maintainer right now. So any support for 6.0 will rely on some motivated developer to step forward to do the work & submit patches to libvirt upstream.

Comment 2 Daniel Berrangé 2020-04-17 13:46:45 UTC
I got some spare time to add vbox 6.0 and 6.1 support. Note it has only been compile tested, so we're looking for interested users to try it out and give feedback...

https://www.redhat.com/archives/libvir-list/2020-April/msg00849.html

Comment 3 Daniel Berrangé 2020-09-11 17:00:00 UTC
Closing since the referenced patches were merged.


Note You need to log in before you can comment on or make changes to this bug.