Bug 1729747 - lapack is not compatible with fortran 90+
Summary: lapack is not compatible with fortran 90+
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: lapack
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-14 06:35 UTC by RudraB
Modified: 2020-01-06 14:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-06 14:23:58 UTC
Type: Bug


Attachments (Terms of Use)

Description RudraB 2019-07-14 06:35:07 UTC
Description of problem:
Hi,

when `lapack` can be used as a library, it is not callable as a module.

Version-Release number of selected component (if applicable):
lapack-3.8.0-12.fc30.x86_64

How reproducible:
every time. It is a general property.

Steps to Reproduce:
Consider a simple `hello_world`
Program  hello
  use iso_fortran_env
  Implicit None
  integer(int32), parameter :: lda = 3, lwmax = 100
  real(real32) :: a(lda, lda), w(lda)
  integer(int32) :: i, j, lwork, info, work
  write(*,*) "Hello"
  LWORK = -1
  CALL DSYEV( 'Vectors', 'Upper', lda, A, LDA, W, WORK, LWORK, INFO )

End Program  hello

this can be compiled as gfortran -llapack hello.f90

But, codes where lapack is used as a module, can not be compiled, as example given http://www.netlib.org/lapack95/lug95/node52.html 

Actual results:
The code in the link gives error:
  8 |   USE LA_PRECISION, ONLY: WP => SP
      |      1
Fatal Error: Cannot open module file ‘la_precision.mod’ for reading at (1): No such file or directory

Comment 1 Tom "spot" Callaway 2020-01-06 14:23:58 UTC
Apologies for the delay in responding. I believe you are confusing two different pieces of software.

* LAPACK: http://www.netlib.org/lapack/ 
* LAPACK95: http://www.netlib.org/lapack95/

LAPACK95 has not been updated since November 2000. It contains support for modules.

LAPACK has no support for modules, so there is nothing missing from Fedora's version.

The example you cite is specifically for LAPACK95, which is not currently part of Fedora. The licensing of LAPACK95 is unclear, as no license is included in the available source code. Additionally, I suspect it is quite likely that it is incompatible with modern LAPACK.


Note You need to log in before you can comment on or make changes to this bug.