Bug 172982 - Map problems when UI is enlarged
Summary: Map problems when UI is enlarged
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-11 19:22 UTC by Chris Lumens
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 17:39:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lumens 2005-11-11 19:22:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
When there is an amount of blank space on either side of the map (because you've made the window larger or because the map widget is in a bigger box, like in anaconda) and click to zoom in, you get weird behavior.  The zoomed in map is too large, covers an area not in the highlighted part of the "pick your region" map, and has a large amount of dead space in that extended region where dots are not selected.

Version-Release number of selected component (if applicable):
system-config-date-1.7.99.5-1

How reproducible:
Always

Steps to Reproduce:
1. Switch to the map screen.  Drag the edge of the window out to make the window larger, so there is blank space on either side of the map.
2. Hover over the Australia region, noting that the highlighted space goes as far west as some dots east of Madagascar.
3. Click on the region.  Notice that the zoomed in map has now extended all the way to the left edge of the window and that the region covered by the zoom in includes as far west as South Africa.
4. Attempt to select dots on Africa.  Notice that the arrows point far to the east, into the region covered by the highlighted region on the main map.
  

Expected Results:  The map should not be resized so much when it is zoomed in.  It should also only include the region shown by the highlighted section on the main map.  I'm running into this when including s-c-date's widgets in anaconda.

Additional info:

Comment 1 Nils Philippsen 2005-11-21 17:39:04 UTC
Fixed in system-config-date-1.7.99.6.


Note You need to log in before you can comment on or make changes to this bug.