Bug 1730046 - Optimize by not stopping (restart) selfheal deamon (shd) when a volume is stopped unless it is the last volume
Summary: Optimize by not stopping (restart) selfheal deamon (shd) when a volume is st...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Mohammed Rafi KC
QA Contact: nchilaka
URL:
Whiteboard: shd-multiplexing
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-15 17:17 UTC by Atin Mukherjee
Modified: 2020-01-20 09:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-20 09:30:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Atin Mukherjee 2019-07-15 17:17:03 UTC
This bug was initially created as a copy of Bug #1471742

I am copying this bug because: 



Description of problem:
=======================
When there is more than 1 volume in a cluster setup, if we stop one volume, we stop and start even the selfheal deamons on all nodes.
This is completely unncessary and waste of resources.
We are immediately restarting shd because there are still other volumes available. This means we are interfering momentarly in the heal process for any file which was getting healed , and this means the file takes a bit more time to heal.

before stopping the healdeamon as part of volume stop, we must check if there are any other volumes associated with the heal deamon and avoid stopping and regenerating a new shd process when it is not required
Version-Release number of selected component (if applicable):


How reproducible:
========
always


Steps to Reproduce:
1.create 3 volumes all 1x3
2.note down the shd pids
3.now stop v1
4. check the shd pid, it can be seen they are restarted
5. now stop v2, again it can be seen the shd pids are restarted

Actual results:
===========

Expected results:
don't stop shds unless it is the last volume


Note You need to log in before you can comment on or make changes to this bug.