Bug 173005 - Missing link /usr/lib/libelf.so -> libelf.so.1
Missing link /usr/lib/libelf.so -> libelf.so.1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: elfutils (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-11 22:12 EST by Boris Vinarsky
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 22:12:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Vinarsky 2005-11-11 22:12:05 EST
Description of problem:
Soft link which is present on 32 bit RHEL 3.0 /usr/lib/libelf.so -> libelf.so.1
is missing on 64 bit RHEL 3.0. Applications that should run on both 32 bit
systems and 64 bit systems in compatibilty mode and which rely on that link fail.
Version-Release number of selected component (if applicable):
elfutils-libelf-devel-0.94-1

How reproducible:
Always

Steps to Reproduce:
1.Run on 32 bit machine rpm -qvl elfutils-libelf-devel-0.94-1
2.Run on 64 bit machine rpm -qvl elfutils-libelf-devel-0.94-1
 
Actual results:
On 32 bit system:
rpm -qvl elfutils-libelf-devel-0.94-1
-rw-r--r--    1 root    root             9574 Jan 16  2004 /usr/include/gelf.h
-rw-r--r--    1 root    root            11791 Jan 16  2004 /usr/include/libelf.h
-rw-r--r--    1 root    root             1293 Jan 16  2004 /usr/include/nlist.h
-rw-r--r--    1 root    root           149882 Jan 16  2004 /usr/lib/libelf.a
lrwxrwxrwx    1 root    root               11 Jan 16  2004 /usr/lib/libelf.so ->
libelf.so.1

On 64 bit system
rpm -qvl elfutils-libelf-devel-0.94-1
-rw-r--r--    1 root    root             9574 Jan 16  2004 /usr/include/gelf.h
-rw-r--r--    1 root    root            11791 Jan 16  2004 /usr/include/libelf.h
-rw-r--r--    1 root    root             1293 Jan 16  2004 /usr/include/nlist.h
-rw-r--r--    1 root    root           223598 Jan 16  2004 /usr/lib64/libelf.a
lrwxrwxrwx    1 root    root               11 Jan 16  2004 /usr/lib64/libelf.so
-> libelf.so.1

Expected results:
The 64 bit package should include 32 bit components in /usr/lib or the link
should be included into some compatibility package.

Additional info:

Workaround on 64 bit machine:                                                  
                              
cd /usr/lib
ln -s libelf.so.1 libelf.so
Comment 1 Roland McGrath 2005-11-14 22:12:04 EST
You can install the 32-bit elfutils-libelf-devel package if you want to do
32-bit builds.  rpm should not complain about the header files being in both
packages since they will be identical.

Note You need to log in before you can comment on or make changes to this bug.