Bug 1730059 - mesa-libGL & libglvnd-glx circular dependency
Summary: mesa-libGL & libglvnd-glx circular dependency
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mesa-libGLU
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-15 18:18 UTC by Randy
Modified: 2019-07-15 19:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Randy 2019-07-15 18:18:32 UTC
Description of problem:

Can't install these two packages 

[root]# rpm -i mesa-libGL-18.0.5-4.el7_6.x86_64.rpm
error: Failed dependencies:
        libglvnd-glx(x86-64) >= 1:1.0.1-0.7 is needed by mesa-libGL-18.0.5-4.el7_6.x86_64

[root]# rpm -i libglvnd-glx-1.0.1-0.8.git5baa1e5.el7.x86_64.rpm
error: Failed dependencies:
        mesa-libGL(x86-64) >= 13.0.4-1 is needed by libglvnd-glx-1:1.0.1-0.8.git5baa1e5.el7.x86_64



Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 7.6 (Maipo)


How reproducible:

Every time 

Steps to Reproduce:

Download packages and install. 

Actual results:

Packages do not install. 

Expected results:

Packages should install.


Note You need to log in before you can comment on or make changes to this bug.