Bug 173013 - You can't use passwords longer than 16 characters
You can't use passwords longer than 16 characters
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pam_mysql (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ignacio Vazquez-Abrams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-12 07:20 EST by Vilius Šumskas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 03:31:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vilius Šumskas 2005-11-12 07:20:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; WOW64; SV1; .NET CLR 2.0.50727)

Description of problem:
You can't use passwords longer than 16 characters due to limitation in pam_mysql itself.

Version-Release number of selected component (if applicable):
pam_mysql-0.50-6

How reproducible:
Always

Steps to Reproduce:
1. create /etc/pam.d/imap file (or whatever) with content "auth sufficient pam_mysql.so user=mail passwd=123456789012345678 host=localhost db=mail table=accountuser usercolumn=username passwdcolumn=password crypt=1 logtable=log logmsgcolumn=msg logusercolumn=user loghostcolumn=host logpidcolumn=pid logtimecolumn=time"

2. create database "mail" and mysql user "mail" with password "123456789012345678" to login to.

3. try to login to cyrus (or whatever) through pam_mysql. and you will get "access denied" error.

4. however with password "1234567890123456" everything works as expected.

Actual Results:  You will get "access denied" error.

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2005-11-13 12:50:34 EST
An updated package has been built. Please update pam_mysql and see if the
problem persists.
Comment 2 Vilius Šumskas 2005-11-13 15:27:46 EST
It my sound stupid, but where should I get it? :). yum and up2date doesn't 
return any new updates.
Comment 3 Ignacio Vazquez-Abrams 2005-11-13 22:12:05 EST
Well, it was *just* pushed out today so the only placed you'd find it is at
download.fedora.redhat.com, at least until the mirrors sync up.
Comment 4 Vilius Šumskas 2005-11-14 03:22:52 EST
It seems that it fixed the problem.

Thanks for fast actions taken!

Note You need to log in before you can comment on or make changes to this bug.