Bug 173021 - Bonding driver no longer supports vlan tagging
Bonding driver no longer supports vlan tagging
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-12 11:59 EST by Hrunting Johnson
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 20:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hrunting Johnson 2005-11-12 11:59:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Prior to this kernel release, one could setup tagged vlan devices on bonded interfaces.  As of this kernel release, that functionality exists.  A kernel bug has already been filed.  The fix is trivial.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
1. setup bonded interface
2. setup vlan over bonded interface
3.
  

Actual Results:  Fails.

Expected Results:  Succeeds.

Additional info:

http://marc.theaimsgroup.com/?l=linux-netdev&m=113053431732175&w=2
Comment 1 Hrunting Johnson 2005-11-29 14:47:27 EST
This bug still exists with the latest release, 2.6.14-1.1644_FC4.  Here is the
upstream patch from 2.6.15-rc1 which fixes it:

http://www.kernel.org/git/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=8e3babcd69ec0fde874838e276eb0b211c6a5647;hp=fd7a516efbcdabf5d7b9307ca9fe48b511b7d123

It'd be really nice if FC4 could start shipping this trivial fix.
Comment 2 Dave Jones 2005-11-29 18:15:46 EST
thanks, I just added this to CVS. Will be in build 1647 and higher.
You can grab early builds as they happen at
http://people.redhat.com/davej/kernels/Fedora/FC4
Comment 3 Hrunting Johnson 2005-11-29 19:37:00 EST
(In reply to comment #2)
> thanks, I just added this to CVS. Will be in build 1647 and higher.
> You can grab early builds as they happen at
> http://people.redhat.com/davej/kernels/Fedora/FC4


Thanks Dave.  We'll try it out when it's available and give you feedback.
Comment 4 Hrunting Johnson 2005-11-30 19:21:37 EST
Dave, I tried the 1647 kernel out today on a high-volume server and it worked as
expected with no side effects.  I'd say the problem is fixed.

Note You need to log in before you can comment on or make changes to this bug.