Bug 173023 - gctags --cxref option causes segmentation fault
gctags --cxref option causes segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 173022 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-12 12:33 EST by Hideki IWAMOTO
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 21.4-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 22:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hideki IWAMOTO 2005-11-12 12:33:43 EST
Description of problem:
gctags causes segmentation fault when --cxref(-x) option is used.

Version-Release number of selected component (if applicable):


How reproducible:
Use --cxref(-x) option.

Steps to Reproduce:
1.touch a.c
2.gctags -x a.c

  
Actual results:
Segmentation fault

Expected results:

Additional info:
Comment 1 Hideki IWAMOTO 2005-11-12 12:35:44 EST
*** Bug 173022 has been marked as a duplicate of this bug. ***
Comment 2 Hideki IWAMOTO 2005-11-12 12:47:36 EST
ctags inclued in emacs-21.4 does not have this bug.
This bug was introduced by etags-14.21-17.11-diff.patch.

A patch was posted to emacs-pretest-bug@gnu.org about 1 week ago.
But emacs people seem to have no interest in this.
http://lists.gnu.org/archive/html/emacs-pretest-bug/2005-11/msg00063.html
Comment 3 Hideki IWAMOTO 2005-11-18 10:01:20 EST
This bug was fixed in upstream etags.
http://savannah.gnu.org/cgi-bin/viewcvs/emacs/emacs/lib-src/etags.c.diff?
r1=3.49&r2=3.50&sortby=date
Comment 4 Jens Petersen 2005-11-21 21:44:16 EST
Ok, thanks for the report.

Updating to latest etags.c in next build.
Comment 5 Jens Petersen 2005-11-23 23:07:03 EST
Updating to latest etags.c code in next devel build.
Should be in emacs-21.4-9.
Comment 6 Jens Petersen 2006-03-27 22:56:49 EST
Fix should be in FC5.

Note You need to log in before you can comment on or make changes to this bug.