Bug 173026 - Would like the "Printing Manager" to accomodate scaling
Would like the "Printing Manager" to accomodate scaling
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-12 13:24 EST by Kim Lux
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 12:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2005-11-12 13:24:57 EST
Description of problem: 
 
I've got a pdf document that prints ridiculously small.  I'd like to scale it 
up in print size when I print it on my lexmark laser printer.  
 
 
Version-Release number of selected component (if applicable): 
 
rpm -q cups 
cups-1.1.23-15.1 
 
I dunno the name of the print manager exe to get the version of it. I think it 
is kdeprint and I think it is part of kdelibs.  Not sure. I'm running 
kde3.4.3-fc4, updated via repositories.   
 
How reproducible: 
 
Every time. 
 
Steps to Reproduce: 
1. Open print manager from pdf viewer. (any of them) 
2. File->Print 
3. Try enter "scaling", "125" into "Additional Tags" fields 
   
Actual results: 
 
1) Page prints as normal. 
 
Expected results: 
 
1) Page prints 25% larger.  
 
Additional info: 
 
I suspect this value is supposed to be added in "Driver Settings" in printer 
Options, but I cannot figure out how to add another field for scaling.  It 
would be nice if it was there to begin with as most laser printers allow 
scaling.  
 
Kudos to the person who wrote help for kdeprint(manager).  Lots of interesting 
info in there explaining things.  
 
This page shows how to scale manually using lp/lpr commands: 
http://www.cups.org/doc-1.1/sum.html#4_5_2  You probably know this stuff !  
 
I also find it confusing to know the difference between the "Additional Tags", 
"Driver settings" and "Filters".  Are "Driver Settings" really lpr options ? 
 
BTW: the printing system in Linux is generally excellent, especially with the 
later kernels that find the printers properly. (!)  Well done.
Comment 1 Kim Lux 2005-11-12 13:38:13 EST
I tried printing the document to a ps file and then manually setting up the 
scaling as follows:  
 
lpr -o scaling=125 testprint.ps 
lpr -o scaling=150 -o sides=two-sided-short-edge -o number-up=2 testprint.ps 
 
Both of these commands work as expected, ie print the page as expected, except 
for the scaling component. 
 
My printer driver is a Lexmark Optra S 1855 installed on /dev/lp0 
 
Maybe this printer doesn't handle the scaling option ? 
 
  
Comment 2 Kim Lux 2005-11-12 13:39:23 EST
I know that the printer itself does handle scaling because we used to do it 
from Windows.  Not that we would ever go back to Windows ! 
Comment 3 Tim Waugh 2006-05-12 12:31:26 EDT
Try 'fitplot=true'.  This should scale the PDF to fit the page.

Note You need to log in before you can comment on or make changes to this bug.