Bug 173031 - Program crashes when viewing html emails
Program crashes when viewing html emails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-12 14:03 EST by Mike Chambers
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 00:53:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My Internet folder with an email that crashes (163.72 KB, application/octet-stream)
2005-11-15 12:25 EST, Mike Chambers
no flags Details

  None (edit)
Description Mike Chambers 2005-11-12 14:03:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Fedora/1.7.12-2

Description of problem:
When you open up evolution, whether you click on an html email, or it's already highlighted from being there previously, it crashes.

Version-Release number of selected component (if applicable):
evolution-2.4.1-7 evolution-data-server-1.4.1.1-1 gtkhtml3-3.8.1-2 gtkhtml2-2.6.3-1 gnome-python2-gtkhtml2-2.12.1-6

How reproducible:
Always

Steps to Reproduce:
1.Open Evolution
2.Click on an html email
3.
  

Actual Results:  Program crashes, even while working offline (I think).

Expected Results:  Program should download the html content and allow to be viewed.

Additional info:

This was after a rawhide install on 11/11.
Comment 1 Dave Malcolm 2005-11-14 13:00:15 EST
Thanks for this bug report.

Those packages are working for me.  Please can you install the debuginfo
packages, then run evolution under gdb, and obtain a stack backtrace  using "t a
a bt") when evolution crashes.

See http://fedoraproject.org/wiki/StackTraces for more information

Thanks.
Comment 2 Mike Chambers 2005-11-14 16:23:45 EST
I think I may have fixed the problem.  I usually make backups of my
/home/user/.evolution folder before I reinstall a system.  And I think the
cache/http dir was causing it, as I deteled the stuff in that dir, and so far
(well only two) it hasn't crashed on html emails.  I will watch for a few more
just to make sure, and close if it that is the case.
Comment 3 Mike Chambers 2005-11-15 07:44:03 EST
Ok, the problem still exists, so here is the attempted backstrace, let me know
if I need to do something different...

(gdb) t a a bt

Thread 6 (Thread -1298429008 (LWP 4914)):
#0  0x003f3402 in __kernel_vsyscall ()
#1  0x03e1f846 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x02b549b7 in e_msgport_wait (mp=0x89efc48) at e-msgport.c:511
#3  0x02b550ad in thread_dispatch (din=0x89f0f40) at e-msgport.c:874
#4  0x03e1dbe2 in start_thread () from /lib/libpthread.so.0
#5  0x00a6353e in clone () from /lib/libc.so.6

Thread 5 (Thread -1249367120 (LWP 4913)):
#0  0x003f3402 in __kernel_vsyscall ()
#1  0x03e1f846 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x02b549b7 in e_msgport_wait (mp=0x89f0f10) at e-msgport.c:511
#3  0x02b550ad in thread_dispatch (din=0x89f0eb8) at e-msgport.c:874
#4  0x03e1dbe2 in start_thread () from /lib/libpthread.so.0
#5  0x00a6353e in clone () from /lib/libc.so.6

Thread 4 (Thread -1259856976 (LWP 4911)):
#0  0x003f3402 in __kernel_vsyscall ()
#1  0x03e1f846 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x02b549b7 in e_msgport_wait (mp=0x8c5df20) at e-msgport.c:511
#3  0x0565981d in sync_op (emss=Variable "emss" is not available.
) at em-sync-stream.c:225
#4  0x05659aa4 in stream_close (stream=0x8c41dd4) at em-sync-stream.c:323
#5  0x02c40c93 in camel_stream_close (stream=0x8c41dd4) at camel-stream.c:153
#6  0x0564acd3 in em_html_stream_finalize (object=0x8c41dd4) at em-html-stream.c:99
#7  0x02c3b27e in camel_object_unref (vo=0x8c41dd4) at camel-object.c:925
#8  0x05645cf0 in efh_format_do (mm=0x8c38328) at em-format-html.c:1234
#9  0x056679b3 in mail_msg_received (e=0x89f0610, msg=0x8c38328, data=0x0) at
mail-mt.c:556
#10 0x02b55041 in thread_dispatch (din=0x89f0610) at e-msgport.c:826
#11 0x03e1dbe2 in start_thread () from /lib/libpthread.so.0
#12 0x00a6353e in clone () from /lib/libc.so.6

Thread 3 (Thread -1249367120 (LWP 4910)):
#0  0x003f3402 in __kernel_vsyscall ()
#1  0x03e1f846 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0

Thread 2 (Thread -1238484048 (LWP 4909)):
#0  0x003f3402 in __kernel_vsyscall ()
#1  0x03e1f846 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x02b549b7 in e_msgport_wait (mp=0x89f0668) at e-msgport.c:511
#3  0x02b550ad in thread_dispatch (din=0x89f0610) at e-msgport.c:874
#4  0x03e1dbe2 in start_thread () from /lib/libpthread.so.0
#5  0x00a6353e in clone () from /lib/libc.so.6

Thread 1 (Thread -1208711504 (LWP 4907)):
#0  0x00d88057 in FcFreeTypeCharIndex () from /usr/lib/libfontconfig.so.1
#1  0x00dd5152 in pango_fc_font_create_metrics_for_context () from
/usr/lib/libpangoft2-1.0.so.0
#2  0x00dd52f0 in pango_fc_font_get_glyph () from /usr/lib/libpangoft2-1.0.so.0
#3  0x003f0e21 in ?? () from /usr/lib/pango/1.4.0/modules/pango-basic-fc.so
#4  0x03e3ec87 in pango_engine_shape_get_type () from /usr/lib/libpango-1.0.so.0
#5  0x03e4dad9 in pango_shape () from /usr/lib/libpango-1.0.so.0
#6  0x02e84ae8 in html_get_glyphs_non_tab () from /usr/lib/libgtkhtml-3.8.so.15
#7  0x02e6d417 in html_painter_text_itemize_and_prepare_glyphs () from
/usr/lib/libgtkhtml-3.8.so.15
#8  0x02e6d6d8 in html_painter_glyphs_destroy () from /usr/lib/libgtkhtml-3.8.so.15
#9  0x02e6dafb in html_painter_alloc_font () from /usr/lib/libgtkhtml-3.8.so.15
#10 0x02e60327 in html_font_manager_get_attr () from /usr/lib/libgtkhtml-3.8.so.15
#11 0x02e60639 in html_font_manager_get_font () from /usr/lib/libgtkhtml-3.8.so.15
#12 0x02e6d0dd in html_painter_get_space_asc () from /usr/lib/libgtkhtml-3.8.so.15
#13 0x02e80c3d in html_text_calc_part_width () from /usr/lib/libgtkhtml-3.8.so.15
#14 0x02e80f14 in html_text_get_link_rectangle () from /usr/lib/libgtkhtml-3.8.so.15
#15 0x02e69511 in html_object_calc_preferred_width () from
/usr/lib/libgtkhtml-3.8.so.15
#16 0x02e3b781 in html_clueflow_style_equals () from /usr/lib/libgtkhtml-3.8.so.15
#17 0x02e69511 in html_object_calc_preferred_width () from
/usr/lib/libgtkhtml-3.8.so.15
#18 0x02e36e73 in html_clue_remove () from /usr/lib/libgtkhtml-3.8.so.15
#19 0x02e3e92e in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#20 0x02e7a604 in html_table_add_cell () from /usr/lib/libgtkhtml-3.8.so.15
#21 0x02e69511 in html_object_calc_preferred_width () from
/usr/lib/libgtkhtml-3.8.so.15
#22 0x02e75fd4 in html_table_set_cell () from /usr/lib/libgtkhtml-3.8.so.15
#23 0x02e76410 in html_table_set_cell () from /usr/lib/libgtkhtml-3.8.so.15
#24 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#25 0x02e3b83d in html_clueflow_style_equals () from /usr/lib/libgtkhtml-3.8.so.15
#26 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#27 0x02e36eb9 in html_clue_remove () from /usr/lib/libgtkhtml-3.8.so.15
#28 0x02e3e8df in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#29 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#30 0x02e36eb9 in html_clue_remove () from /usr/lib/libgtkhtml-3.8.so.15
#31 0x02e3e8df in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#32 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#33 0x02e36eb9 in html_clue_remove () from /usr/lib/libgtkhtml-3.8.so.15
#34 0x02e3e8df in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#35 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#36 0x02e36eb9 in html_clue_remove () from /usr/lib/libgtkhtml-3.8.so.15
#37 0x02e3e8df in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#38 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#39 0x02e36eb9 in html_clue_remove () from /usr/lib/libgtkhtml-3.8.so.15
#40 0x02e3e8df in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#41 0x02e7a54b in html_table_add_cell () from /usr/lib/libgtkhtml-3.8.so.15
#42 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#43 0x02e7a5b8 in html_table_add_cell () from /usr/lib/libgtkhtml-3.8.so.15
#44 0x02e69511 in html_object_calc_preferred_width () from
/usr/lib/libgtkhtml-3.8.so.15
#45 0x02e75fd4 in html_table_set_cell () from /usr/lib/libgtkhtml-3.8.so.15
#46 0x02e76410 in html_table_set_cell () from /usr/lib/libgtkhtml-3.8.so.15
#47 0x02e694e2 in html_object_calc_min_width () from /usr/lib/libgtkhtml-3.8.so.15
#48 0x02e785bf in html_table_add_cell () from /usr/lib/libgtkhtml-3.8.so.15
#49 0x02e693a8 in html_object_set_max_width () from /usr/lib/libgtkhtml-3.8.so.15
#50 0x02e3b916 in html_clueflow_style_equals () from /usr/lib/libgtkhtml-3.8.so.15
#51 0x02e693a8 in html_object_set_max_width () from /usr/lib/libgtkhtml-3.8.so.15
#52 0x02e3e9a9 in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#53 0x02e693a8 in html_object_set_max_width () from /usr/lib/libgtkhtml-3.8.so.15
#54 0x02e3e9a9 in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#55 0x02e693a8 in html_object_set_max_width () from /usr/lib/libgtkhtml-3.8.so.15
#56 0x02e3e9a9 in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#57 0x02e693a8 in html_object_set_max_width () from /usr/lib/libgtkhtml-3.8.so.15
#58 0x02e3e9a9 in html_clueh_new () from /usr/lib/libgtkhtml-3.8.so.15
#59 0x02e693a8 in html_object_set_max_width () from /usr/lib/libgtkhtml-3.8.so.15
#60 0x02e56109 in html_engine_calc_size () from /usr/lib/libgtkhtml-3.8.so.15
#61 0x02e5af5b in html_engine_expose () from /usr/lib/libgtkhtml-3.8.so.15
#62 0x02e5f7e1 in html_engine_refresh_fonts () from /usr/lib/libgtkhtml-3.8.so.15
#63 0x02e5fcf3 in html_engine_begin () from /usr/lib/libgtkhtml-3.8.so.15
#64 0x02e26af2 in gtk_html_stream_close () from /usr/lib/libgtkhtml-3.8.so.15
#65 0x0564adc3 in emhs_sync_close (stream=0x8c41dd4) at em-html-stream.c:140
#66 0x056596bc in emcs_gui_received (source=0x8c5dc38, cond=G_IO_IN,
data=0x8c41dd4) at em-sync-stream.c:164
#67 0x00c27c9c in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#68 0x00c00a50 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#69 0x00c03a66 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#70 0x00c03d53 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#71 0x005ae600 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#72 0x0805cd2d in main (argc=1, argv=0xbff66364) at main.c:602
#73 0x009ad50f in __libc_start_main () from /lib/libc.so.6
#74 0x0804f881 in _start ()
Comment 4 Dave Malcolm 2005-11-15 11:55:00 EST
Thanks.  Can you supply a copy of an email that crashes it for you as well?

(Looking at the backtrace, it looks like you _might_ be running into a
fontconfig problem (though IIRC that was fixed about a week ago).  It may help
if you run "fc-cache -fv" to force regeneration of your font cache.  But that's
simply a hunch at this point)
Comment 5 Mike Chambers 2005-11-15 12:25:51 EST
Created attachment 121077 [details]
My Internet folder with an email that crashes

This is my Internet folder, that contains an html email from Inside PC Magazine
that I get at least once a day.  This is one instance that causes evolution to
crash.
Comment 6 Mike Chambers 2005-11-15 12:29:05 EST
[root@scrappy ~]# fc-cache -fv
fc-cache: "/usr/share/fonts": caching, 0 fonts, 3 dirs
fc-cache: "/usr/share/fonts/default": caching, 0 fonts, 2 dirs
fc-cache: "/usr/share/fonts/default/Type1": caching, 35 fonts, 0 dirs
fc-cache: "/usr/share/fonts/default/ghostscript": caching, 17 fonts, 0 dirs
fc-cache: "/usr/share/fonts/bitstream-vera": caching, 10 fonts, 0 dirs
fc-cache: "/usr/share/fonts/bitmap-fonts": caching, 32 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1": caching, 29 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/OTF": caching, 0 fonts, 0 dirs
fc-cache: "/root/.fonts": skipping, no such directory
fc-cache: succeeded

[mike@scrappy ~]$ fc-cache -fv
fc-cache: "/usr/share/fonts": skipping, no write access
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1": skipping, no write access
fc-cache: "/usr/X11R6/lib/X11/fonts/OTF": skipping, no write access
fc-cache: "/home/mike/.fonts": caching, 107 fonts, 0 dirs
fc-cache: succeeded
Comment 7 Mike Chambers 2005-11-15 12:31:16 EST
OK, after running the above fc-cache commands, the email that I attached can now
be seen and evo not crash.  Let me see when/if a few more html emails come
through adn see what happens and I'll report the status.

Note You need to log in before you can comment on or make changes to this bug.