Bug 1730319 - Creation of snapshot while connection from host to storage is blocked succeeded when it should fail.
Summary: Creation of snapshot while connection from host to storage is blocked succeed...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.5.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
: ---
Assignee: Tal Nisan
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 12:42 UTC by Evelina Shames
Modified: 2019-08-13 12:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-13 12:13:07 UTC
oVirt Team: Storage


Attachments (Terms of Use)
Logs (3.33 MB, application/zip)
2019-07-16 12:42 UTC, Evelina Shames
no flags Details

Description Evelina Shames 2019-07-16 12:42:57 UTC
Created attachment 1591033 [details]
Logs

Description of problem:
On HE environment, creation of snapshot on VM which running on hsm host (doesn't matter if it's HE hsm host or regular hsm host) while connection from the host to VM's storage is blocked should fail.

Version-Release number of selected component (if applicable):
engine - 4.3.5.4-0.1.el7
vdsm-4.30.24-2.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create VM from template
2. Start VM on non SPM host
3. Block connection from host to storage
4. Try to create snapshot - Operation should fail

Actual results:
Operation succeeded

Expected results:
Operation should fail


Additional info:
Logs are attached

Comment 1 Tal Nisan 2019-07-22 14:20:28 UTC
Does the VM have disks? If not it can work as the snapshot creating is only of the configuration

Comment 2 Evelina Shames 2019-07-23 07:18:11 UTC
Yes, the VM has one disk.

Comment 3 Tal Nisan 2019-08-12 14:30:42 UTC
Did you block the connection from the SPM to storage? The snapshot creation is done by the SPM so unless you block it from the storage the operation should work successfully

Comment 4 Evelina Shames 2019-08-13 12:13:07 UTC
No, I block the connection from hsm and the VM enters in 'pause' state and that's why the snapshot creation fails.
I tried to reproduce it on 4.3.6 and seems that the problem was solved - snapshot creation fails as expected, so I'm closing this bug for now.


Note You need to log in before you can comment on or make changes to this bug.