Bug 173039 - Eclipse 3.1.1 fails to start up
Eclipse 3.1.1 fails to start up
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-12 16:41 EST by Dawid Zamirski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 14:27:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Startup log (14.61 KB, text/plain)
2005-11-12 16:42 EST, Dawid Zamirski
no flags Details

  None (edit)
Description Dawid Zamirski 2005-11-12 16:41:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Since I've upgraded eclipse to the newet version (3.1.1), it doesn't startup anymore. The version that was in updates-testing (same release as in official updates) was starting up and woking execpt software updates. Once the rpm has been posted to the updates channel, I removed the testing version and replaced with the one from the official repo. After the update, albeit the same version tag, it doesn't statrup (errors in attached log file). Removing ~/.eclipse and /usr/share/eclipse and all plugins doesn't help.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.4

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to the newest version 3.1.1
2. Start eclipse
3. Error message pops up with path to the log file (attached)
  

Actual Results:  Failure on startup

Expected Results:  Eclipse startup

Additional info:

[maners@athlon64 ~]$ rpm -qa | grep gcj
libgcj-devel-4.0.1-4.fc4
libgcj-src-4.0.1-4.fc4
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2
libgcj-4.0.1-4.fc4
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_31rh.FC4.2
libgcj-4.0.1-4.fc4

[maners@athlon64 ~]$ rpm -qa | grep java
jakarta-commons-dbcp-javadoc-1.2.1-3jpp_1fc
struts11-javadoc-1.1-1jpp_7fc
xerces-j2-javadoc-other-2.6.2-4jpp_5fc
gnu.getopt-javadoc-1.0.10-1jpp
puretls-javadoc-0.9-0.b4.2jpp
xml-commons-resolver-javadoc-1.1-3jpp
bcel-javadoc-5.1-5jpp
junit-javadoc-3.8.1-4jpp
libglade-java-2.10.1-5
libglade-java-devel-2.10.1-5
ant-javamail-1.6.2-3jpp_8fc
ldapjdk-javadoc-4.17-1jpp_2fc
antlr-javadoc-2.7.4-2jpp_1fc
jakarta-commons-beanutils-javadoc-1.7.0-1jpp_4fc
jakarta-commons-pool-javadoc-1.2-2jpp_1fc
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1
cryptix-javadoc-3.2.0-5jpp
jdepend-javadoc-2.6-3jpp
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2
xalan-j2-javadoc-2.6.0-3jpp
avalon-logkit-javadoc-1.2-3jpp
libgtk-java-2.6.2-3
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2
jakarta-commons-modeler-javadoc-1.1-3jpp_4fc
ant-javadoc-1.6.2-3jpp_8fc
jakarta-commons-el-javadoc-1.0-2jpp_3fc
jakarta-commons-logging-javadoc-1.0.4-2jpp_4fc
regexp-javadoc-1.3-1jpp_5fc
xerces-j2-javadoc-dom3-2.6.2-4jpp_5fc
xml-commons-apis-javadoc-1.0-0.b2.6jpp_12fc
classpathx-mail-javadoc-1.1-1jpp
cryptix-asn1-javadoc-20011119-5jpp
avalon-framework-javadoc-4.1.5-1jpp
jakarta-commons-validator-javadoc-1.1.4-1jpp
log4j-javadoc-1.2.11-1jpp
mx4j-javadoc-2.1.0-1jpp_7fc
gnu-crypto-javadoc-2.0.1-1jpp_5fc
jakarta-commons-digester-javadoc-1.6-2jpp_4fc
jakarta-commons-launcher-javadoc-0.9-3jpp_1fc
xerces-j2-javadoc-apis-2.6.2-4jpp_5fc
xerces-j2-javadoc-xni-2.6.2-4jpp_5fc
xml-commons-which-javadoc-1.0-0.b2.6jpp_12fc
gcc-java-4.0.1-4.fc4
jakarta-commons-lang-javadoc-2.1-1jpp
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_31rh.FC4.2
jakarta-commons-collections-javadoc-3.1-1jpp_4fc
jakarta-taglibs-standard-javadoc-1.1.1-4jpp_1fc
jlex-javadoc-1.2.6-2jpp
classpathx-jaf-javadoc-1.0-2jpp_3fc
jakarta-commons-fileupload-javadoc-1.0-3jpp_1fc
xerces-j2-javadoc-impl-2.6.2-4jpp_5fc
oro-javadoc-2.0.8-2jpp
java_cup-javadoc-0.10-0.k.2jpp
java_cup-0.10-0.k.2jpp
java_cup-manual-0.10-0.k.2jpp
libgnome-java-2.10.1-3

[maners@athlon64 ~]$ rpm -qa | grep eclipse
eclipse-ecj-3.1.1-1jpp_1fc.FC4.4
eclipse-rcp-3.1.1-1jpp_1fc.FC4.4
eclipse-platform-3.1.1-1jpp_1fc.FC4.4
Comment 1 Dawid Zamirski 2005-11-12 16:42:42 EST
Created attachment 120990 [details]
Startup log
Comment 2 Andrew Overholt 2005-11-14 09:38:07 EST
(In reply to comment #0)
> Since I've upgraded eclipse to the newet version (3.1.1), it doesn't startup
> anymore. The version that was in updates-testing (same release as in official
> updates) was starting up and woking

I don't understand.  If you had the version that *was* in updates testing, there
should not have been anything to upgrade once that update went final because it
is the exact same.

> execpt software updates.

> Once the rpm has been posted to the updates channel, I removed the testing
> version and replaced with the one from the official repo.

Why did you do this?  How did you remove the first set of RPMs?

> After the update, albeit the same version tag, it doesn't statrup (errors in
> attached log file). Removing ~/.eclipse and /usr/share/eclipse and all
> plugins doesn't help.

You shouldn't need to remove /usr/share/eclipse if you remove all the RPMs
(don't forget about libswt3-gtk2).  What is the difference between removing the
RPMs and removing "all plugins"?

> [maners@athlon64 ~]$ rpm -qa | grep gcj
> [...]
> java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1
> java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2
> java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2
> libgcj-4.0.1-4.fc4
> java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_31rh.FC4.2
> libgcj-4.0.1-4.fc4

Why are things showing up twice?  Perhaps your update of gcc* (including *gcj*)
did not update finish correctly?  What do you get when you run:

java -version
gcj --version
gcc --version

?

Are you familiar with the alternatives system?  I think you might have your
alternatives set up incorrectly.  Let's determine what version(s) of gij/gcj you
have first and go from there.

> [maners@athlon64 ~]$ rpm -qa | grep java
> [...]
> xerces-j2-javadoc-impl-2.6.2-4jpp_5fc
> oro-javadoc-2.0.8-2jpp

While I think this is probably inconsequential and unrelated to your current
problem, you do have packages that are part of JPackage but not part of FC.

> [maners@athlon64 ~]$ rpm -qa | grep eclipse
> eclipse-ecj-3.1.1-1jpp_1fc.FC4.4
> eclipse-rcp-3.1.1-1jpp_1fc.FC4.4
> eclipse-platform-3.1.1-1jpp_1fc.FC4.4

Okay.  Do you also have libswt3-gtk2?  Are you perhaps running the 32-bit gcc*
on x86_64 but attempting to run the 64-bit Eclipse?  That will not work.  You
can see by doing:

rpm -qa --queryformat "%{name}-%{version}-%{release}.%{arch}\n" | grep gcj
rpm -qa --queryformat "%{name}-%{version}-%{release}.%{arch}\n" | egrep
"eclipse|swt"
Comment 3 Dawid Zamirski 2005-11-14 12:36:53 EST
> I don't understand.  If you had the version that *was* in updates testing, 
> there should not have been anything to upgrade once that update went final 
> because it is the exact same.

I was aware that the package from testing is the same as in official updates,
and of course, it didn't show up as update. I just wanted to make sure that my
rpm comes from official updates channel (it might not make much of a sense, but
I feel mentally better when the package comes form official updates :-P) What I
did was yum remove eclipse-platform and any other packages with "eclipse" in its
name. Then I installed it with yum again with updates-testing disabled.

> You shouldn't need to remove /usr/share/eclipse if you remove all the RPMs
> (don't forget about libswt3-gtk2).  What is the difference between removing
> the RPMs and removing "all plugins"?

At my first attempt I didn't remove any files manually, but since eclipse didn't
start I removed the rpms again and then any left overs from previous install
(~/.eclipse and /usr/share/eclipse). I had some plugins that I installed
manually (PHPEclipse, JScipt etc) that I extracted to /usr/share/eclipse adnthey
worked fine with 3.0 M6 (I didn't know at that time about ~/.eclipse directory)
Therfore I thought that some of them migh cause the failure and for that reason
I removed /usr/share/eclipse manually after rpm unistall.

> Why are things showing up twice?  Perhaps your update of gcc* (including
>  *gcj*) did not update finish correctly?  What do you get when you run:
<snip>

Well, I don't know why they are showing up twice (both seem to be x84_64) and I
think it might be the result of playing with smartpm some time ago.

[maners@athlon64 ~]$ java --version
java version "1.4.2"
gij (GNU libgcj) version 4.0.1 20050727 (Red Hat 4.0.1-5)

[maners@athlon64 ~]$ gcj --version
gcj (GCC) 4.0.1 20050727 (Red Hat 4.0.1-5)

[maners@athlon64 ~]$ gcc --version
gcc (GCC) 4.0.1 20050727 (Red Hat 4.0.1-5)


[maners@athlon64 ~]$ rpm -qa --queryformat
"%{name}-%{version}-%{release}.%{arch}\n" | grep gcj
libgcj-devel-4.0.1-4.fc4.x86_64
libgcj-src-4.0.1-4.fc4.x86_64
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1.x86_64
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2.x86_64
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_31rh.FC4.2.x86_64
libgcj-4.0.1-4.fc4.x86_64
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_31rh.FC4.2.x86_64
libgcj-4.0.1-4.fc4.i386

[maners@athlon64 ~]$ rpm -qa --queryformat
"%{name}-%{version}-%{release}.%{arch}\n" | egrep "eclipse|swt"
libswt3-gtk2-3.1.1-1jpp_1fc.FC4.4.x86_64
eclipse-ecj-3.1.1-1jpp_1fc.FC4.4.x86_64
eclipse-rcp-3.1.1-1jpp_1fc.FC4.4.x86_64
eclipse-platform-3.1.1-1jpp_1fc.FC4.4.x86_64

I'll remove the duplicated packages and will see if it helps
Comment 4 Dawid Zamirski 2005-11-14 13:01:53 EST
It seems that I have something broken with my rpm pakcages. When I try to remove
any of the duplicated java-1.4.2-gcj-compat packages I get scriptlet error:

[root@athlon64 ~]# rpm -e java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1
/var/tmp/rpm-tmp.75084: line 8: /usr/bin/rebuild-security-providers: No such
file or directory
error: %postun(java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1.x86_64) scriptlet
failed, exit status 127

Comment 5 Dawid Zamirski 2005-11-14 13:58:07 EST
Ok, now it works! :-) The problem was caused by jpackage-utils-1.6.5 that I had
installed which probably came form JPackage repo. I removed it and installed the
1.6.3 which is in official fedora repository and this solved the scriptlet
error. After reinstaling all the packages, it works fine. Thank You.
Comment 6 Andrew Overholt 2005-11-14 14:27:01 EST
(In reply to comment #5)
> Ok, now it works! :-) The problem was caused by jpackage-utils-1.6.5 that I had
> installed which probably came form JPackage repo. I removed it and installed the
> 1.6.3 which is in official fedora repository and this solved the scriptlet
> error. After reinstaling all the packages, it works fine. Thank You.

Phew!  That's good news.  Nice working tracking that down :)

Note You need to log in before you can comment on or make changes to this bug.