Bug 1730420 - [abrt] flatpak: check_call(): subprocess.py:347:check_call:subprocess.CalledProcessError: Command '['flatpak', 'run', '--filesystem=home', '--filesystem=/tmp', '--command=gdb', '--devel', 'org.gnome.Epiphany.Devel//master', '/usr/libexec/webkit2gtk-4.0...
Summary: [abrt] flatpak: check_call(): subprocess.py:347:check_call:subprocess.CalledP...
Keywords:
Status: CLOSED DUPLICATE of bug 1723965
Alias: None
Product: Fedora
Classification: Fedora
Component: flatpak
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:4c0722cd87be2179cc0b99bc6f1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-16 16:22 UTC by Michael Catanzaro
Modified: 2019-07-16 19:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-16 19:45:37 UTC


Attachments (Terms of Use)
File: backtrace (1.33 KB, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details
File: cgroup (399 bytes, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details
File: cpuinfo (1.51 KB, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details
File: environ (5.61 KB, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details
File: mountinfo (3.90 KB, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details
File: namespaces (129 bytes, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details
File: open_fds (244 bytes, text/plain)
2019-07-16 16:22 UTC, Michael Catanzaro
no flags Details

Description Michael Catanzaro 2019-07-16 16:22:03 UTC
Description of problem:
flatpak-coredumpctl is crashing (python exception) whenever gdb crashes. It needs to handle CalledProcessError here.

Version-Release number of selected component:
flatpak-1.4.2-2.fc30

Additional info:
reporter:       libreport-2.10.1
cmdline:        /usr/bin/python3 /usr/bin/flatpak-coredumpctl org.gnome.Epiphany.Devel//master
crash_function: check_call
exception_type: subprocess.CalledProcessError
executable:     /usr/bin/flatpak-coredumpctl
interpreter:    python3-3.7.3-3.fc30.x86_64
kernel:         5.1.17-300.fc30.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
subprocess.py:347:check_call:subprocess.CalledProcessError: Command '['flatpak', 'run', '--filesystem=home', '--filesystem=/tmp', '--command=gdb', '--devel', 'org.gnome.Epiphany.Devel//master', '/usr/libexec/webkit2gtk-4.0/WebKitWebProcess', '/tmp/tmptrocbps8']' returned non-zero exit status 139.

Traceback (most recent call last):
  File "/usr/bin/flatpak-coredumpctl", line 83, in <module>
    coredumper.run()
  File "/usr/bin/flatpak-coredumpctl", line 58, in run
    subprocess.check_call(flatpak_command)
  File "/usr/lib64/python3.7/subprocess.py", line 347, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['flatpak', 'run', '--filesystem=home', '--filesystem=/tmp', '--command=gdb', '--devel', 'org.gnome.Epiphany.Devel//master', '/usr/libexec/webkit2gtk-4.0/WebKitWebProcess', '/tmp/tmptrocbps8']' returned non-zero exit status 139.

Local variables in innermost frame:
popenargs: (['flatpak', 'run', '--filesystem=home', '--filesystem=/tmp', '--command=gdb', '--devel', 'org.gnome.Epiphany.Devel//master', '/usr/libexec/webkit2gtk-4.0/WebKitWebProcess', '/tmp/tmptrocbps8'],)
kwargs: {}
retcode: 139
cmd: ['flatpak', 'run', '--filesystem=home', '--filesystem=/tmp', '--command=gdb', '--devel', 'org.gnome.Epiphany.Devel//master', '/usr/libexec/webkit2gtk-4.0/WebKitWebProcess', '/tmp/tmptrocbps8']

Comment 1 Michael Catanzaro 2019-07-16 16:22:07 UTC
Created attachment 1591116 [details]
File: backtrace

Comment 2 Michael Catanzaro 2019-07-16 16:22:08 UTC
Created attachment 1591117 [details]
File: cgroup

Comment 3 Michael Catanzaro 2019-07-16 16:22:09 UTC
Created attachment 1591118 [details]
File: cpuinfo

Comment 4 Michael Catanzaro 2019-07-16 16:22:10 UTC
Created attachment 1591119 [details]
File: environ

Comment 5 Michael Catanzaro 2019-07-16 16:22:11 UTC
Created attachment 1591120 [details]
File: mountinfo

Comment 6 Michael Catanzaro 2019-07-16 16:22:11 UTC
Created attachment 1591121 [details]
File: namespaces

Comment 7 Michael Catanzaro 2019-07-16 16:22:12 UTC
Created attachment 1591122 [details]
File: open_fds

Comment 8 Michael Catanzaro 2019-07-16 19:45:37 UTC

*** This bug has been marked as a duplicate of bug 1723965 ***


Note You need to log in before you can comment on or make changes to this bug.