Bug 1730555 - Ctrl-Alt-F2 aborts GUI session
Summary: Ctrl-Alt-F2 aborts GUI session
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-17 06:32 UTC by pkoz
Modified: 2019-10-29 21:26 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
journalctl text from the point when Ctrl-Alt-F2 was pressed. (50.24 KB, text/plain)
2019-07-17 06:32 UTC, pkoz
no flags Details

Description pkoz 2019-07-17 06:32:34 UTC
Created attachment 1591287 [details]
journalctl text from the point when Ctrl-Alt-F2 was pressed.

Description of problem:
Changing to terminal with Ctrl-Alt-F2 aborts the running GUI session.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Ctrl-Alt-F2
2.Ctrl-Alt-F1
3.Instead of getting back to GUI session one can only log in to a brand new session.
4.Tried with the older kernels, the same result.

Actual results:


Expected results:


Additional info:
Just prior to being confronted with the described effect I did two things:
1. Changed the hostname (but, since then, I changed it back to the old one, didn't help)
2. Made a series of upgrades:

[root@gygv ~]# dnf history info 335
Transaction ID : 335
Begin time     : Mon 15 Jul 2019 09:05:27 PM CEST
Begin rpmdb    : 1484:eeda72d0fa7574c10e9006673960ab35a49c158a
End time       : Mon 15 Jul 2019 09:06:17 PM CEST (50 seconds)
End rpmdb      : 1484:8d8ca6d7b4949c4fb1477a50dd81b9d56155a6fc
User           : Peter <peter>
Return-Code    : Success
Releasever     : 30
Command Line   : upgrade
Packages Altered:
    Install  kernel-5.1.17-300.fc30.x86_64         @updates
    Install  kernel-core-5.1.17-300.fc30.x86_64    @updates
    Install  kernel-modules-5.1.17-300.fc30.x86_64 @updates
    Upgrade  kernel-headers-5.1.17-300.fc30.x86_64 @updates
    Upgraded kernel-headers-5.1.16-300.fc30.x86_64 @@System
    Upgrade  libXi-1.7.10-1.fc30.x86_64            @updates
    Upgraded libXi-1.7.9-9.fc30.x86_64             @@System
    Upgrade  libevdev-1.7.0-1.fc30.x86_64          @updates
    Upgraded libevdev-1.6.0-2.fc30.x86_64          @@System
    Removed  kernel-5.1.12-300.fc30.x86_64         @@System
    Removed  kernel-core-5.1.12-300.fc30.x86_64    @@System
    Removed  kernel-modules-5.1.12-300.fc30.x86_64 @@System

[root@gygv ~]# dnf history info 336
Transaction ID : 336
Begin time     : Tue 16 Jul 2019 06:53:05 PM CEST
Begin rpmdb    : 1484:8d8ca6d7b4949c4fb1477a50dd81b9d56155a6fc
End time       : Tue 16 Jul 2019 06:53:22 PM CEST (17 seconds)
End rpmdb      : 1484:b11106b85e104c4ba5726f94007dd612dff2bd72
User           : Peter <peter>
Return-Code    : Success
Releasever     : 30
Command Line   : upgrade
Packages Altered:
    Upgrade  enchant2-2.2.5-1.fc30.x86_64    @updates
    Upgraded enchant2-2.2.3-6.fc30.x86_64    @@System
    Upgrade  glib2-2.60.5-1.fc30.x86_64      @updates
    Upgraded glib2-2.60.4-1.fc30.x86_64      @@System
    Upgrade  mozjs60-60.8.0-2.fc30.x86_64    @updates
    Upgraded mozjs60-60.7.2-1.fc30.x86_64    @@System
    Upgrade  pcre2-10.33-6.fc30.x86_64       @updates
    Upgraded pcre2-10.33-4.fc30.x86_64       @@System
    Upgrade  pcre2-utf16-10.33-6.fc30.x86_64 @updates
    Upgraded pcre2-utf16-10.33-4.fc30.x86_64 @@System
    Upgrade  postfix-2:3.4.6-1.fc30.x86_64   @updates
    Upgraded postfix-2:3.4.4-3.fc30.x86_64   @@System
    Upgrade  tzdata-2019b-1.fc30.noarch      @updates
    Upgraded tzdata-2019a-1.fc30.noarch      @@System
    Upgrade  tzdata-java-2019b-1.fc30.noarch @updates
    Upgraded tzdata-java-2019a-1.fc30.noarch @@System
Scriptlet output:
   1 warning: /etc/postfix/main.cf created as /etc/postfix/main.cf.rpmnew

[root@gygv ~]# dnf history info 337
Transaction ID : 337
Begin time     : Tue 16 Jul 2019 10:22:02 PM CEST
Begin rpmdb    : 1484:b11106b85e104c4ba5726f94007dd612dff2bd72
End time       : Tue 16 Jul 2019 10:22:06 PM CEST (4 seconds)
End rpmdb      : 1484:f1c38a239fdb3d1292dcfc5e7456bb819de687ee
User           : Peter <peter>
Return-Code    : Success
Releasever     : 30
Command Line   : upgrade
Packages Altered:
    Upgrade  ffmpeg-4.1.4-1.fc30.x86_64      @rpmfusion-free-updates
    Upgraded ffmpeg-4.1.3-2.fc30.x86_64      @@System
    Upgrade  ffmpeg-libs-4.1.4-1.fc30.x86_64 @rpmfusion-free-updates
    Upgraded ffmpeg-libs-4.1.3-2.fc30.x86_64 @@System
    Upgrade  libavdevice-4.1.4-1.fc30.x86_64 @rpmfusion-free-updates
    Upgraded libavdevice-4.1.3-2.fc30.x86_64 @@System



Attached is the relevant portion from journalctl.

Comment 1 pkoz 2019-07-17 07:03:40 UTC
I wasn't able to revert most of the new updates, but I could go back to libXi-1.7.9, this didn't help either.

Comment 2 pkoz 2019-07-17 07:11:51 UTC
Actually, my first encounter with the problem was that I couldn't resume a GUI session after "Switch User" on the Mate desktop. It is just my assumption that both the Ctrl-Alt and Switch User failures have the same root cause.

Comment 3 pkoz 2019-07-17 17:13:01 UTC
After having browsed a bit this same bugzilla I came across a number of very similar bug reports, just to name a few: 1630367, 1662057, 1697591, 1662548, 1629409, they are cross-duplicates to each other.

The common denominator with my case seems to be this in Xorg.log, which appears in mine as well:
modeset(0): failed to set mode: Invalid argument
EnterVT failed for screen 0

1662548 is the most similar to what I have experienced. https://bugzilla.redhat.com/show_bug.cgi?id=1630367#c18 is not for me, I use the modesetting driver

Unfortunately there is such a big spectrum of hardware types, software packages and log files mentioned in those reports that I am at a sort of loss when trying to figure out what I should supply to make myself useful. I'll trye these:

kernel-5.1.17-300.fc30.x86_64
xorg-x11-server-Xorg-1.20.5-4.fc30.x86_64
lightdm-1.28.0-7.fc30.x86_64
xorg-x11-server-common-1.20.5-4.fc30.x86_64
xorg-x11-drv-libinput-0.28.2-1.fc30.x86_64
xorg-x11-drv-fbdev-0.5.0-3.fc30.x86_64
xorg-x11-drv-evdev-2.10.6-4.fc30.x86_64

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

Comment 4 pkoz 2019-07-21 19:34:51 UTC
Switching between terminals seems to depend on the external monitor:

1. No external monitor, just the Lenovo Y50 laptop monitor: works fine.
2. Lenovo HDMI port ==> HDMI-to-VGA adapter ==> Asus VH242 with only VGA input: works fine
3. Lenovo HDMI port ==> HDMI-to-DVI cable ==> another Asus VH242 with both DVI and VGA input: X session crashes with (EE) modeset(0): failed to set mode: Invalid argument.
4. Lenovo HDMI port ==> HDMI-to-VGA adapter ==> another Asus VH242 with both DVI and VGA input: not tried, next week

In case 3, Linux automatically switches laptop display off and uses the external Asus monitor on startup, whereas in case 2, Linux starts in a dual-monitor setup with the laptop monitor as primary (i.e. the Mate panel appears on the laptop monitor)

In case 3, even after having switched to the laptop monitor, X crashes at the terminal switch attempt, only after removing physically the HDMI connector from Lenovo (case 1) switching terminals is possible.

Comment 5 pkoz 2019-07-28 19:16:28 UTC
4. Lenovo HDMI port ==> HDMI-to-VGA adapter ==> another Asus VH242 with both DVI and VGA input: much the same as case 3, looks like the AH242 with VGA & DVI is not identified properly?

Comment 6 pkoz 2019-10-29 21:26:22 UTC
3. Lenovo HDMI port ==> HDMI-to-DVI cable ==> another Asus VH242 with both DVI and VGA input:

today I tried and tested this again, and switching between the alphanumeric and graphical terminals works fine, X session survives.

kernel-5.3.7-200.fc30.x86_64
xorg-x11-server-Xorg-1.20.5-7.fc30.x86_64
lightdm-1.28.0-7.fc30.x86_64
xorg-x11-server-common-1.20.5-7.fc30.x86_64
xorg-x11-drv-libinput-0.29.0-1.fc30.x86_64
xorg-x11-drv-fbdev-0.5.0-3.fc30.x86_64
xorg-x11-drv-evdev-2.10.6-4.fc30.x86_64


Note You need to log in before you can comment on or make changes to this bug.