Bug 1730720 - WARNING and ERROR in log files when running on hw withou supported hw
Summary: WARNING and ERROR in log files when running on hw withou supported hw
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1779111
TreeView+ depends on / blocked
 
Reported: 2019-07-17 12:52 UTC by Robin Hack
Modified: 2020-01-06 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1779111 (view as bug list)
Environment:
Last Closed: 2020-01-06 16:43:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robin Hack 2019-07-17 12:52:49 UTC
Description of problem:


Version-Release number of selected component (if applicable):
tuned-2.10.0-6.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. run in 1minutetip environment (no graphic card present or unsupported graphic card)
2. looks like: tuned-adm profile balanced triggers this ERROR/WARNING


Actual results:
2019-07-17 08:20:15,713 ERROR    tuned.utils.commands: Error when reading file '/sys/class/drm/card0/device/power_method': '[Errno 2] No such file or directory: u'/sys/class/drm/card0/device/power_method''
2019-07-17 08:20:15,713 WARNING  tuned.plugins.plugin_video: radeon_powersave is not supported on 'card0'


in /var/log/tuned/tuned.log

Expected results:
Maybe warning or just ignore non presence of gpu?

Additional info:

Comment 3 Ondřej Lysoněk 2019-07-17 13:19:30 UTC
Agreed that we should not log the error.

I'm not sure yet about the warning - it might make sense to omit it if no GPU is found, however in a sense, it's still unsupported tuning, so a warning is appropriate. I think I'd rather keep the warning, we should not hide stuff like that from the user. The user can always modify the profile if a certain tuning doesn't make sense for their system. However we could print a better warning message such as "no GPU found".

Comment 4 Jaroslav Škarvada 2020-01-06 16:43:33 UTC
Red Hat Enterprise Linux version 7 entered the Maintenance Support 1 phase in August 2019. In this phase only qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available. Other errata advisories may be delivered as appropriate.

This bug has been reviewed by Support and Engineering representative and does not meet the inclusion criteria for Maintenance Support 1 phase.

For more information about Red Hat Enterprise Linux Lifecycle, please see https://access.redhat.com/support/policy/updates/errata#Maintenance_Support_1_Phase.

Comment 5 RHEL Program Management 2020-01-06 16:43:40 UTC
Development Management has reviewed and declined this request. You may appeal this decision by using your Red Hat support channels, who will make certain  the issue receives the proper prioritization with product and development management.

https://www.redhat.com/support/process/production/#howto


Note You need to log in before you can comment on or make changes to this bug.